summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-03-13 01:34:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-13 20:49:44 +0100
commitf764f0724d0ec2a649446f82a1a1c739b8bf472a (patch)
treee2bb23f1f86f53ce43b28dc55be9683e4f97a4f6
parentdev-libs/libqtxdg: add a missing new dependency (diff)
downloadgentoo-f764f0724d0ec2a649446f82a1a1c739b8bf472a.tar.gz
gentoo-f764f0724d0ec2a649446f82a1a1c739b8bf472a.tar.bz2
gentoo-f764f0724d0ec2a649446f82a1a1c739b8bf472a.zip
media-gfx/lximage-qt: remove 'x11-libs/libfm' dependency
This requirement seems to have been removed a few years ago. - https://github.com/lxqt/lximage-qt/commit/79ea1a06 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/11353 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-gfx/lximage-qt/lximage-qt-0.14.1-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/lximage-qt/lximage-qt-0.14.1-r1.ebuild b/media-gfx/lximage-qt/lximage-qt-0.14.1-r1.ebuild
new file mode 100644
index 000000000000..7e74167d0fd4
--- /dev/null
+++ b/media-gfx/lximage-qt/lximage-qt-0.14.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="LXImage Image Viewer - GPicView replacement"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.6.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/libexif
+ >=x11-libs/libfm-qt-0.12.0:=
+ x11-libs/libX11
+ x11-libs/libXfixes
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"