summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2017-03-31 15:46:14 +0200
committerMichael Orlitzky <mjo@gentoo.org>2017-04-25 11:14:42 -0400
commitf7d3914fd79f06f5e0820e453054a127c0f52211 (patch)
treea8a44105eb2498d5e1c68c76c55258d35ee69647
parentdev-python/certifi: Version bump to 2017.4.17 (diff)
downloadgentoo-f7d3914fd79f06f5e0820e453054a127c0f52211.tar.gz
gentoo-f7d3914fd79f06f5e0820e453054a127c0f52211.tar.bz2
gentoo-f7d3914fd79f06f5e0820e453054a127c0f52211.zip
dev-php/jsonlint: Add version bump 1.6.0
Add version bump 1.6.0 Gentoo-Bug: 613898
-rw-r--r--dev-php/jsonlint/Manifest1
-rw-r--r--dev-php/jsonlint/jsonlint-1.6.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/jsonlint/Manifest b/dev-php/jsonlint/Manifest
index 189838be97ba..d313715a474a 100644
--- a/dev-php/jsonlint/Manifest
+++ b/dev-php/jsonlint/Manifest
@@ -1 +1,2 @@
DIST jsonlint-1.4.0.tar.gz 10893 SHA256 e97ff9b23037a2d6ec3d548a273c345dea097b66e72d5bb8b30e66ce765fe46d SHA512 29a23a86ece17f43a471ba8952785e820eff537ddce019935d776492a0d0ccf68c5f0e1f5f3d63b8b12efbe0acc1f7e3fa91d4b9d48bae2e1eec4f3c4b9094b1 WHIRLPOOL 90d08bbe063c61066e3a29ce391934e906ceaf9ae2e80ac67e57f94088e14f1dd27e1faf3f5331cb35c6b209a3e38f35634154cad5b9d80cd62389a0dfd99929
+DIST jsonlint-1.6.0.tar.gz 11327 SHA256 8b4ca6c92839ae78e128381330647fca9352245acc330d8794a284514fc3619b SHA512 16538781807a4ca73de83e7be69d0fc2b530dd9b25f2b9a2ee3f1156dd5ebccb79e9489b873f307718ca2da658a1ae7cef5144adb32f2d1e5c34bd192d496c79 WHIRLPOOL 6d628e1c03e565267196be72f1d9610c79388bfe775d9a2681edc0e5aaebcf776eec6123036b3effd4b69338d52fdb7b3e69fa33930436ee113cf439ecbc54f3
diff --git a/dev-php/jsonlint/jsonlint-1.6.0.ebuild b/dev-php/jsonlint/jsonlint-1.6.0.ebuild
new file mode 100644
index 000000000000..ea1e8f975dc1
--- /dev/null
+++ b/dev-php/jsonlint/jsonlint-1.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="JSON Lint for PHP"
+HOMEPAGE="https://github.com/Seldaek/jsonlint"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-php/phpunit )"
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
+ sed -i -e "s:__DIR__:'${S}/src/Seld/JsonLint':" "${S}"/autoload-test.php || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/Seld/JsonLint"
+ doins -r src/Seld/JsonLint/. "${FILESDIR}"/autoload.php
+ dodoc README.mdown
+}
+
+src_test() {
+ phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
+}