summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-12-09 00:57:48 -0500
committerTim Harder <radhermit@gentoo.org>2016-12-09 00:57:48 -0500
commitf8206022fa1ed920ed1de2dbf3666b8a68b2689d (patch)
tree26fbb9d2d80330b00c249f421ebdd9049a6d24a4
parentapp-misc/byobu: version bump to 5.113 (diff)
downloadgentoo-f8206022fa1ed920ed1de2dbf3666b8a68b2689d.tar.gz
gentoo-f8206022fa1ed920ed1de2dbf3666b8a68b2689d.tar.bz2
gentoo-f8206022fa1ed920ed1de2dbf3666b8a68b2689d.zip
sys-fs/fuse: version bump to 3.0.0_rc3
-rw-r--r--sys-fs/fuse/Manifest1
-rw-r--r--sys-fs/fuse/fuse-3.0.0_rc3.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/sys-fs/fuse/Manifest b/sys-fs/fuse/Manifest
index a149bbe4dfce..256cc7ee17ee 100644
--- a/sys-fs/fuse/Manifest
+++ b/sys-fs/fuse/Manifest
@@ -4,3 +4,4 @@ DIST fuse-2.9.6.tar.gz 640070 SHA256 0cb48bbc7106632d15a0c6bb582496c9884b869e329
DIST fuse-2.9.7.tar.gz 661138 SHA256 832432d1ad4f833c20e13b57cf40ce5277a9d33e483205fc63c78111b3358874 SHA512 f47304d9c7a1815f7a2905b7bdb7785d4c10292a80c8dc1ec45d895af96bc6ffd6d84ff2617bd976a1d0867ab8ec1a404a5a05ace85a69ecca830f371d08f8e2 WHIRLPOOL 826f77920356c129cda5ca158e37327688d2aa044c0ecdaabe8d52e724b0349813460d876571672bcb59a5b8004018593abdb314187b6b6706fee69b9eadaae7
DIST fuse-3.0.0rc1.tar.gz 747644 SHA256 2b0b3a0489d1e06e2390af71c99dba1738e85f991a76bb5c0414e89dabc79715 SHA512 eda0832a5b0f480d0969601b89be6b7486276079ef8e53372699523d8be1d0961d427d7de29d7a538edcb7443240c7d2e3621c286180e8f27fdd1be9c4d31c9b WHIRLPOOL d0c62481e07cc96bb0939616db5c87b9d7c53e8e217128f68f3caed68fbcc109d56e88fbe5e7834ad2e695116b922197552d70c314f88058c407d39497ba65b5
DIST fuse-3.0.0rc2.tar.gz 735331 SHA256 e50dc509205857ec1e95040ea4b75c008e3863dafd700e62c675f8a3578d415c SHA512 e2b6f53e217100140bc71cecfee95805f0c15e3c9c395894659b9d1e8107b5207dfb9d18535a43fe40d95b3681972112c82113c16428172730f7f811db300037 WHIRLPOOL 61e2399a4d49001f3b9b36ea67403622ced5136efd1c6d1422bce0a32aeaa903a387b98c306f7e94f5f3b94d218a9c0dcbf3a03408b78e111f66ed6a25508d8e
+DIST fuse-3.0.0rc3.tar.gz 744606 SHA256 f8c64ebc8e3e29c33f0877c673a4a1a060569299690f32dc682ba4a2aa1ee50b SHA512 a50d12d70ee44c217f198a231bf37b323d36741aacb5d6b2fbf6f8cfc645d9106d7f05f7cc7be29bd64098b48797f8c53a239194bf49e714b9a0dc12bf885e35 WHIRLPOOL 55a66383ca712458d5006a043ca71f157522621df9283e6c42b6c44b2548869a72b7804485db69be3d60c194da906bf4660fb16fab10f8d5afae60eb4670c7a8
diff --git a/sys-fs/fuse/fuse-3.0.0_rc3.ebuild b/sys-fs/fuse/fuse-3.0.0_rc3.ebuild
new file mode 100644
index 000000000000..197cc9fa9a5a
--- /dev/null
+++ b/sys-fs/fuse/fuse-3.0.0_rc3.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils libtool linux-info udev toolchain-funcs
+
+MY_P=${P/_/}
+
+DESCRIPTION="An interface for filesystems implemented in userspace"
+HOMEPAGE="https://github.com/libfuse/libfuse"
+SRC_URI="https://github.com/libfuse/libfuse/releases/download/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="examples kernel_linux kernel_FreeBSD static-libs"
+
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+DEPEND="virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use kernel_linux ; then
+ if kernel_is lt 2 6 9 ; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use user-mode utils"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # sandbox violation with mtab writability wrt #438250
+ # don't sed configure.in without eautoreconf because of maintainer mode
+ sed -i 's:umount --fake:true --fake:' configure || die
+ elibtoolize
+
+ default
+}
+
+src_configure() {
+ econf \
+ INIT_D_PATH="${EPREFIX}/etc/init.d" \
+ MOUNT_FUSE_PATH="${EPREFIX}/sbin" \
+ UDEV_RULES_PATH="${EPREFIX}/$(get_udevdir)/rules.d" \
+ $(use_enable static-libs static) \
+ --disable-example
+}
+
+src_install() {
+ local DOCS=( AUTHORS README.md doc/README.NFS doc/kernel.txt )
+ default
+
+ if use examples ; then
+ docinto examples
+ dodoc example/*
+ fi
+
+ if use kernel_linux ; then
+ newinitd "${FILESDIR}"/fuse.init fuse
+ elif use kernel_FreeBSD ; then
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ newinitd "${FILESDIR}"/fuse-fbsd.init fuse
+ else
+ die "We don't know what init code install for your kernel, please file a bug."
+ fi
+
+ prune_libtool_files
+ rm -rf "${D}"/dev
+
+ dodir /etc
+ cat > "${ED}"/etc/fuse.conf <<-EOF
+ # Set the maximum number of FUSE mounts allowed to non-root users.
+ # The default is 1000.
+ #
+ #mount_max = 1000
+
+ # Allow non-root users to specify the 'allow_other' or 'allow_root'
+ # mount options.
+ #
+ #user_allow_other
+ EOF
+}