summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-09 14:48:01 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-09 14:49:06 +0200
commitf8aa432f6b686e1817459c0ce27b02ee7dfc574e (patch)
treea86884568ca181579b998ea48568ba515f1b8c33
parentdev-libs/svrcore: Fix src_install #521544, bump to EAPI5 (diff)
downloadgentoo-f8aa432f6b686e1817459c0ce27b02ee7dfc574e.tar.gz
gentoo-f8aa432f6b686e1817459c0ce27b02ee7dfc574e.tar.bz2
gentoo-f8aa432f6b686e1817459c0ce27b02ee7dfc574e.zip
dev-libs/svrcore: Bump #583780
Package-Manager: portage-2.3.0_rc1
-rw-r--r--dev-libs/svrcore/Manifest1
-rw-r--r--dev-libs/svrcore/files/svrcore-4.1-gentoo.patch100
-rw-r--r--dev-libs/svrcore/svrcore-4.1.2.ebuild36
3 files changed, 137 insertions, 0 deletions
diff --git a/dev-libs/svrcore/Manifest b/dev-libs/svrcore/Manifest
index 7cbebeda0bfe..90f6b3096b67 100644
--- a/dev-libs/svrcore/Manifest
+++ b/dev-libs/svrcore/Manifest
@@ -1 +1,2 @@
DIST svrcore-4.0.4.tar.bz2 217076 SHA256 4772fb4705492de11f10d3e020f0ceca2541415c009ae5444988d6becca36a58 SHA512 4a63e2618ef8f508e71adf212eefae56e3c9d9898b924f405399bb99793de57bd178a3417f9e837c474e7960b6eb8a3cbe775b420c8fecbd974e89b4196b78fc WHIRLPOOL 0bf45637685cb03753cd68840381cd5c906e01a61f813156e756e99fa97e7c6d61bc96b4c1f18aa016acf45d54d6288f733c39bf259c241416c1efc89cb0fc93
+DIST svrcore-4.1.2.tar.bz2 263891 SHA256 67e51a868c8dc2ddbf5661ecb0a07dea7721a9ed99f6261cedd3351bfc4cd023 SHA512 9d148ec9c568f1183e44006fec83b4e43b0cef56d5a04fce122fab1e9a0c0bfe39919de81c5a4d7adb2258fb7f16b4d327da20cdb4d948810e968c422d62ad40 WHIRLPOOL ef21e7e94bd9ea1a1d64666c01099581054949bf7faa07055aa2b430388ad2ba2722fcc4065fb480c9bb5d334470dc37c8aea4a5f7eec4450a843390d95a2be3
diff --git a/dev-libs/svrcore/files/svrcore-4.1-gentoo.patch b/dev-libs/svrcore/files/svrcore-4.1-gentoo.patch
new file mode 100644
index 000000000000..346407e124e3
--- /dev/null
+++ b/dev-libs/svrcore/files/svrcore-4.1-gentoo.patch
@@ -0,0 +1,100 @@
+diff -uNr a/m4/nspr.m4 b/m4/nspr.m4
+--- a/m4/nspr.m4 2016-04-22 06:30:23.000000000 +1000
++++ b/m4/nspr.m4 2016-06-08 15:06:49.923333338 +1000
+@@ -52,28 +52,6 @@
+ ],
+ AC_MSG_RESULT(no))
+
+-# see if we are doing an "in-tree" build with the other
+-# mozilla components
+-if test -z "$nspr_inc" -o -z "$nspr_lib" ; then
+- for nsprpath in "../../dist" "../../dist/*.OBJ" ; do
+- savedir=`pwd`
+- cd $nsprpath
+- abs_nsprpath=`pwd`
+- cd $savedir
+- if test -f "$abs_nsprpath/include/nspr/nspr.h" ; then
+- nspr_inc="-I$abs_nsprpath/include/nspr"
+- elif test -f "$abs_nsprpath/include/nspr.h" ; then
+- nspr_inc="-I$abs_nsprpath/include"
+- fi
+- if test -d "$abs_nsprpath/lib" ; then
+- nspr_lib="-L$abs_nsprpath/lib"
+- fi
+- if test -n "$nspr_inc" -a -n "$nspr_lib" ; then
+- break
+- fi
+- done
+-fi
+-
+ # if NSPR is not found yet, try pkg-config
+ # last resort
+ if test -z "$nspr_inc" -o -z "$nspr_lib" ; then
+diff -uNr a/m4/nss.m4 b/m4/nss.m4
+--- a/m4/nss.m4 2016-04-22 06:30:23.000000000 +1000
++++ b/m4/nss.m4 2016-06-08 15:06:49.923333338 +1000
+@@ -52,32 +52,6 @@
+ ],
+ AC_MSG_RESULT(no))
+
+-# see if we are building "in tree" with the
+-# other mozilla components
+-if test -z "$nss_inc" -o -z "$nss_lib"; then
+- nsslibpath=`echo ../../dist/*.OBJ/lib | cut -f1 -d' '`
+- savedir=`pwd`
+- cd $nsslibpath
+- abs_nsslibpath=`pwd`
+- cd $savedir
+- nssincpath=../../dist/public/nss
+- savedir=`pwd`
+- cd $nssincpath
+- abs_nssincpath=`pwd`
+- cd $savedir
+- if test -f "$abs_nssincpath/nss.h" ; then
+- nss_inc="-I$abs_nssincpath"
+- fi
+- if test -d "$abs_nsslibpath" ; then
+- nss_lib="-L$abs_nsslibpath"
+- fi
+- if test -n "$nss_inc" -a -n "$nss_lib" ; then
+- AC_MSG_CHECKING(using in-tree NSS from $nssincpath $nsslibpath)
+- else
+- AC_MSG_CHECKING(could not find in-tree NSS in ../../dist)
+- fi
+-fi
+-
+ # if NSS is not found yet, try pkg-config
+ # last resort
+ if test -z "$nss_inc" -o -z "$nss_lib"; then
+diff -uNr a/src/Makefile.am b/src/Makefile.am
+--- a/src/Makefile.am 2016-04-22 06:30:23.000000000 +1000
++++ b/src/Makefile.am 2016-06-08 15:06:49.923333338 +1000
+@@ -10,8 +10,8 @@
+ Makefile.win \
+ ntgetpin.rc
+
+-lib_LTLIBRARIES = libsvrcore.la
+-include_HEADERS = svrcore.h
++pkglib_LTLIBRARIES = libsvrcore.la
++pkginclude_HEADERS = svrcore.h
+ libsvrcore_la_SOURCES = alt.c \
+ cache.c \
+ errors.c \
+diff -uNr a/svrcore.pc.in b/svrcore.pc.in
+--- a/svrcore.pc.in 2016-04-22 06:30:23.000000000 +1000
++++ b/svrcore.pc.in 2016-06-08 15:06:49.923333338 +1000
+@@ -1,11 +1,11 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+-libdir=@libdir@
+-includedir=@includedir@
++libdir=@libdir@/@PACKAGE@
++includedir=@includedir@/@PACKAGE@
+
+ Name: svrcore
+ Description: Svrcore - Secure PIN handling using NSS crypto
+ Version: @VERSION@
+ Requires: @NSPR_NAME@ >= @NSPR_MIN_VER@ , @NSS_NAME@ >= @NSS_MIN_VER@
+-Libs: -lsvrcore
++Libs: -L${libdir} -lsvrcore
+ Cflags: -I${includedir}
diff --git a/dev-libs/svrcore/svrcore-4.1.2.ebuild b/dev-libs/svrcore/svrcore-4.1.2.ebuild
new file mode 100644
index 000000000000..551a9e980125
--- /dev/null
+++ b/dev-libs/svrcore/svrcore-4.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Mozilla LDAP C SDK"
+HOMEPAGE="http://www.port389.org/"
+SRC_URI="http://www.port389.org/binaries/${P}.tar.bz2"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-libs/nss-3.11
+ >=dev-libs/nspr-4.6"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-4.1-gentoo.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ # cope with libraries being in /usr/lib/svrcore
+ echo "LDPATH='/usr/$(get_libdir)/${PN}'" > "${T}/08svrcore" || die "Unable to create env file"
+ doenvd "${T}/08svrcore"
+}