summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-22 13:43:00 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-20 10:35:42 +0100
commitf94d6da440420a8f91f7222746e227939e6f70d3 (patch)
tree7c4e24531ae46366b88ef7c7c5db49fa30ac7c9d
parentdistutils-r1.eclass: Add pyproject.toml support (diff)
downloadgentoo-f94d6da440420a8f91f7222746e227939e6f70d3.tar.gz
gentoo-f94d6da440420a8f91f7222746e227939e6f70d3.tar.bz2
gentoo-f94d6da440420a8f91f7222746e227939e6f70d3.zip
dev-python/testpath: Build from pyproject.toml
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/testpath/testpath-0.4.4-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/testpath/testpath-0.4.4-r1.ebuild b/dev-python/testpath/testpath-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..96724c835f63
--- /dev/null
+++ b/dev-python/testpath/testpath-0.4.4-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test utilities for code working with files and commands"
+HOMEPAGE="https://github.com/jupyter/testpath https://testpath.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc