summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Novomesky <dnovomesky@gmail.com>2022-07-28 00:13:57 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-08-10 11:31:04 +0300
commitfa324eda3949b757fbd7cb9f53db4f5e64b90585 (patch)
tree409f2bb5a994ea710ae8c91e1a8f05251168c709
parentnet-im/signal-desktop-bin: remove old version (diff)
downloadgentoo-fa324eda3949b757fbd7cb9f53db4f5e64b90585.tar.gz
gentoo-fa324eda3949b757fbd7cb9f53db4f5e64b90585.tar.bz2
gentoo-fa324eda3949b757fbd7cb9f53db4f5e64b90585.zip
dev-cpp/highway: version bump to 1.0.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Daniel Novomesky <dnovomesky@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-cpp/highway/Manifest1
-rw-r--r--dev-cpp/highway/highway-1.0.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-cpp/highway/Manifest b/dev-cpp/highway/Manifest
index bc4c9f9d8add..8bfc6efcdbd9 100644
--- a/dev-cpp/highway/Manifest
+++ b/dev-cpp/highway/Manifest
@@ -1,2 +1,3 @@
DIST highway-0.16.0.tar.gz 1639388 BLAKE2B 660b0079b25a12a2e982b4ba16147b923d167989a7dc1c0cb65ebe5219577f2f02c8774a554fd3fe9e1c10ef7b1cf5db747500bd8acf454e26952722f7b5ac9e SHA512 c08e66f43d9d0b307737b016cfa6c3d3a1df9bd528de435d193388104f34c264866c5ff0da633fc0a6f8c50f21df1ac653e9dd3f6fbfaf227d636411ac14cd47
DIST highway-0.17.0.tar.gz 1694290 BLAKE2B 23ab48e11e8a79eb0469bb4fef7f32148ef6d2a266779a151345fc072213521f46828c2efcb4ab75823f977c619c7727fb064f05d6b3e0aa341698074e6b0e6a SHA512 7e55724c844a09a07cb981a7d8e913dcc5491e07d14ff3e7783a69060b0c470e7d5adc4f5dbeea526b3e109eea8cc9e80605d6b8d2da1b794382e56fd534ba06
+DIST highway-1.0.0.tar.gz 1723558 BLAKE2B f6580ca846aa659c80548e61daec0560dce335cd9c6c449df148398c97c0bafdf86e656a592903494d30de5ced8dcdf4be570b6009a2a5a5457b07f62e770e75 SHA512 19371a4771f4fcba82a125ed09544e2bbbd0d32af103881c8cfa41908a4fb4d6d5c536e1dcfb82628434622f31113a650259582c543275b704b45703805dc101
diff --git a/dev-cpp/highway/highway-1.0.0.ebuild b/dev-cpp/highway/highway-1.0.0.ebuild
new file mode 100644
index 000000000000..89b07a85a587
--- /dev/null
+++ b/dev-cpp/highway/highway-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
+HOMEPAGE="https://github.com/google/highway"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/google/highway.git"
+else
+ SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )"
+
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DHWY_WARNINGS_ARE_ERRORS=OFF
+ )
+
+ use test && mycmakeargs+=( "-DHWY_SYSTEM_GTEST=ON" )
+
+ cmake_src_configure
+}