summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-15 17:23:32 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-15 20:41:29 +0200
commitfacfeb78afb68f6cab4baa4802a42f9054678fc7 (patch)
tree50fef1f3f24b70deefdce60106dd9958b37ac984
parentmedia-plugins/kodi-pvr-mythtv: 5.10.19 version bump (diff)
downloadgentoo-facfeb78afb68f6cab4baa4802a42f9054678fc7.tar.gz
gentoo-facfeb78afb68f6cab4baa4802a42f9054678fc7.tar.bz2
gentoo-facfeb78afb68f6cab4baa4802a42f9054678fc7.zip
dev-python/dbusmock: Bump to 0.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dbusmock/Manifest1
-rw-r--r--dev-python/dbusmock/dbusmock-0.19.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/dbusmock/Manifest b/dev-python/dbusmock/Manifest
index 5a04fd13172c..a78a779f58b6 100644
--- a/dev-python/dbusmock/Manifest
+++ b/dev-python/dbusmock/Manifest
@@ -1 +1,2 @@
DIST dbusmock-0.18.3.tar.gz 72049 BLAKE2B b5ed8ebcae51fedec75fc810e07dc9a38223bcde541cbfddd5d3fbf1ad45d1458e6ad39c1fc69ee77165d751f978cb4483929e823eacbc99a7ae414aebf4d0f0 SHA512 6f7b42eae578ce03024b3b5cc85e82f04a467803f4c8b4cb5193454dcd849038f11e6ce5028ca9dd57ea5a9380c1b754d8fc644b4a24b51deee9e87b409115c3
+DIST dbusmock-0.19.tar.gz 72567 BLAKE2B 973cfa02d1aec29f2151ce077471c49f7def3cee079eb975bbc1abca39cc6d391f5dc4aed40fcd9c9db3fcc25429e689f130dc495b94428b73c64f3c650a9c3a SHA512 9f49cb1818c0de8b774d4ccd0eed35de3b0a95de669e70539699237b5cdfee993da7747dc28375c8f1c26fac83d948b7ce25107d866e28b833b556c6f654706c
diff --git a/dev-python/dbusmock/dbusmock-0.19.ebuild b/dev-python/dbusmock/dbusmock-0.19.ebuild
new file mode 100644
index 000000000000..6bd966090cf6
--- /dev/null
+++ b/dev-python/dbusmock/dbusmock-0.19.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+MY_PN="python-${PN}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="https://github.com/martinpitt/python-dbusmock"
+SRC_URI="https://github.com/martinpitt/${MY_PN}/releases/download/${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-17.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/0.18.2-disable-polkitd-tests.patch
+)
+
+python_test() {
+ nosetests --verbose || die "tests fail under ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( NEWS README.rst )
+
+ distutils-r1_python_install_all
+}