summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-10-25 12:14:51 +0200
committerSebastian Pipping <sping@gentoo.org>2018-10-25 12:15:22 +0200
commitfad1ac4bf2da67bc8b98f04c07173881609c16f4 (patch)
tree95480cc921b39ce1d364aa8d94238d4d4e7bb4d3
parentwww-client/opera-developer: Old. (diff)
downloadgentoo-fad1ac4bf2da67bc8b98f04c07173881609c16f4.tar.gz
gentoo-fad1ac4bf2da67bc8b98f04c07173881609c16f4.tar.bz2
gentoo-fad1ac4bf2da67bc8b98f04c07173881609c16f4.zip
dev-python/flake8: 3.6.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-3.6.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 0e7f55083eba..eb726a169dd9 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -2,3 +2,4 @@ DIST flake8-2.1.0.tar.gz 25010 BLAKE2B 23f89456a28815700f88e2eb3abd29e0936b0c40b
DIST flake8-2.2.5.tar.gz 28333 BLAKE2B 016b5b05b7448dec762e7d5e06fad9d631351d02ba5941a34760c51406164dc2c5508e3c4c54b52c49738c193f815a816d9cd39558bfecaeb83cfddbc6dcc63f SHA512 fe5e06d3a7699e3f348181108f1ab3ee9eb1f2b0422de582a172d3a4aed42a5cf839ef8a5b5b113da1e0c3c2b53ed7b43af1ca24314ea842d0d3d3735eba1dee
DIST flake8-2.5.4.tar.gz 81663 BLAKE2B 89bd5965fe1f6862cadbfc7b614a819a13d4ab147994485542ba519d6151ab11d4b496066c74141020858f468050e7b6dc3d6ce3a89ddf809e9cdc6d130984ef SHA512 31cbec556fc41361ac464d2547275e319ab663c907a4a8644113a2288a9f349bcfbec85197b6dfa13a7db9e82419f01e0f2abc84a347e133c144ea137e0daa28
DIST flake8-3.5.0.tar.gz 140608 BLAKE2B 938ad4406370da27155512355432edd23a824db1d6ee635591628fefad43ee1116256ae7f240496d93941800212ea2479be73fb9ee9bd03c9a54ab70bbce452f SHA512 ac5d1bd9c44ed76c9e5cbd941b24bb552aa76e156b24ccda6cc8440ee90f3a574fdb393665adc75298e4f57111d7ab3115ef21ef9088fb327d0a9703d442450c
+DIST flake8-3.6.0.tar.gz 144684 BLAKE2B 3a6edf83860c6c6a59c150cde47b22eeb17b9e83cb23e4d8f747715b8867093a7f1d1e2bc55c9f9cf43b69463746026d839b0177f2abef746581563a670c3ce0 SHA512 f4377bc7806074a88f88b3652c3061583e576ee515b2b741cee9c6dc18f84f34a7807c93fda9dca3d8b006e379dcee60bb3ae20e6a2e62fd216a82a2b36f2eb5
diff --git a/dev-python/flake8/flake8-3.6.0.ebuild b/dev-python/flake8/flake8-3.6.0.ebuild
new file mode 100644
index 000000000000..5e7f69a1d642
--- /dev/null
+++ b/dev-python/flake8/flake8-3.6.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="https://gitlab.com/pycqa/flake8 https://pypi.org/project/flake8/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND="
+ >=dev-python/pyflakes-2.0.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.5.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' 'pypy*' )
+ $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' 'python2*' pypy )
+"
+PDEPEND="
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${PDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Flake8 falsely assumes it needs pytest-runner unconditionally and will
+ # try to install it, causing sandbox violations.
+ sed -i -e "/setup_requires=\['pytest-runner'\],/d" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}