summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2019-10-20 16:29:50 -0400
committerMike Pagano <mpagano@gentoo.org>2019-10-20 18:24:54 -0400
commitfb2cead45d8f03745e97d9224f9f989aad1c8229 (patch)
tree81e4d0acda04681e6e211fa8a35803a8e64e50bf
parentsys-libs/compiler-rt: Backport crt*.o fix (diff)
downloadgentoo-fb2cead45d8f03745e97d9224f9f989aad1c8229.tar.gz
gentoo-fb2cead45d8f03745e97d9224f9f989aad1c8229.tar.bz2
gentoo-fb2cead45d8f03745e97d9224f9f989aad1c8229.zip
sys-kernel/git-sources: Linux patch 5.4-rc4
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.4_rc4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index f6022a41898b..4c8bf35e8620 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-5.3.tar.xz 108558876 BLAKE2B 0d08eed879d05734e4542f0c93823d43f8dc042a
DIST patch-5.4-rc1.patch 64078480 BLAKE2B 98ed781b61c9e35e8f78939ca0d2ff93d4a1cbad835955226bedb2c12a9b74564cc09a89a6b26d8932b4d1c36f1c6c455faa185d7d2c7eca71b80c927d4cfcd4 SHA512 f9771a13b3179033cd015bfa243ce13acce6d62ace8cc3184182d72933afe6c2928c85cba325b75040e03948b8bdde494ca5bb2b54edc0bc08345ef3470b3d3f
DIST patch-5.4-rc2.patch 64354864 BLAKE2B 864d97e1ed5986448fdb1bc8782e1be236b7023ea9273a0ea589591df79726ddcf26d4241f498b550304d2edfc473af6c73a66eb06e3bceb35f47343e49e83f6 SHA512 b0fd0861c636e49b4e97d0954f966f82d0b8de5e117fd8f2f30b8f92b2e0f93ced475b37272ea37de038cf87cfe70cf6f7e951ef1aa4ef0ed483986a3fab04ec
DIST patch-5.4-rc3.patch 64816978 BLAKE2B 792d0a5149c03ee81c82a1a59b54f64339c5fada49a81115e303deda82a07b3f5f6f5a38205ad01490fc24e7bf7d4d3937e4dd597b6d367e9ddc5f81728a5f27 SHA512 a370c3093d8bfcb6fc6bacaca9e5eff44c32d14f5b49c534298407f1e2625802f93afd407e3f2c002f86adbb64ef3a97a7d29ced09b79600238029e0375c7b4b
+DIST patch-5.4-rc4.patch 65188215 BLAKE2B b21830779c7e941ba794fe574a705b292615a83fc59632a6d6bb40cb30dbb51af38879c65e0e8c7cbe8e2b3393f273866b737b86ae79c327f369e6289e082103 SHA512 7f7efd9b0a26c55974e6ce7f979ee1eabce8e9bdf4f5a2392d9c61e8a9a1f00045ddf683c1574e0fb6849dbca8fc79397e7dc2fbeac3d72b68162c8e1f4d0f11
diff --git a/sys-kernel/git-sources/git-sources-5.4_rc4.ebuild b/sys-kernel/git-sources/git-sources-5.4_rc4.ebuild
new file mode 100644
index 000000000000..7f3937ff7927
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.4_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.3"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}