summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-28 15:11:24 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-28 15:29:52 +1300
commitfb794df3b149e7750357fc843f7e897f59966c5a (patch)
treeb8f34dcd7f64bebfb1a4cddff7f86c99ffa498af
parentdev-perl/List-MoreUtils-XS: Bump to version 0.426.0 (diff)
downloadgentoo-fb794df3b149e7750357fc843f7e897f59966c5a.tar.gz
gentoo-fb794df3b149e7750357fc843f7e897f59966c5a.tar.bz2
gentoo-fb794df3b149e7750357fc843f7e897f59966c5a.zip
dev-perl/List-MoreUtils: Bump to version 0.426.0
Upstream: - Bunch of new functions Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--dev-perl/List-MoreUtils/List-MoreUtils-0.426.0.ebuild28
-rw-r--r--dev-perl/List-MoreUtils/Manifest1
-rw-r--r--dev-perl/List-MoreUtils/files/List-MoreUtils-0.426.0-xs-config.patch78
3 files changed, 107 insertions, 0 deletions
diff --git a/dev-perl/List-MoreUtils/List-MoreUtils-0.426.0.ebuild b/dev-perl/List-MoreUtils/List-MoreUtils-0.426.0.ebuild
new file mode 100644
index 000000000000..8620b5a3283c
--- /dev/null
+++ b/dev-perl/List-MoreUtils/List-MoreUtils-0.426.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=REHSACK
+DIST_VERSION=0.426
+inherit perl-module
+
+DESCRIPTION="Provide the missing functionality from List::Util"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test +xs"
+# See MoreUtils.pm/LICENSE
+LICENSE="Apache-2.0 || ( Artistic GPL-1+ )"
+
+PDEPEND="xs? ( >=dev-perl/List-MoreUtils-XS-0.426.0 )"
+RDEPEND=">=dev-perl/Exporter-Tiny-0.38.0"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.960.0 )
+"
+PATCHES=("${FILESDIR}/${P}-xs-config.patch")
+src_configure() {
+ export LMU_USE_XS="$(usex xs 1 0)"
+ perl-module_src_configure
+}
diff --git a/dev-perl/List-MoreUtils/Manifest b/dev-perl/List-MoreUtils/Manifest
index d9098f755318..cdc456ac6ceb 100644
--- a/dev-perl/List-MoreUtils/Manifest
+++ b/dev-perl/List-MoreUtils/Manifest
@@ -1,2 +1,3 @@
DIST List-MoreUtils-0.418.tar.gz 55111 SHA256 365651edea4e0c806576e4dcfc3dfb98bb4cbb343bc5c3e04cdc7b5b71ed4988 SHA512 7ba4395262c4406e822baf40e5a32aa6d93779a56d2567c4920f085ab2580c376db41e2141e4b9b43860d65122ebe73a03dfb0ed76a32f087b05ca7eb90f6d6e WHIRLPOOL ed63b850aebc353fda7ba9a8b24b1e50527d56b0c672c16cbc534cd90c9fe452a055b05f256d3e05c2d66be3752b1ab20580815d473c0231bfbea55d34c55c40
DIST List-MoreUtils-0.419.tar.gz 55193 SHA256 5f8e65608f5dc583faa6a703d19d277ad46dfc1816e51f8ff34fb8322ed48615 SHA512 d13beb5031d1559c2ec4cb93826e86f0f314c4f10c4fdcac6910de0cb039199599911838eadd499e81cb41025aae2a52d69a259653a9637679a1705c7adcd37a WHIRLPOOL 15c8d91b80aba279d458288edb7bc4c5557f2a84560ff284e0918dee09cf69cd2e320b958b201522e536493d49154d2af3654a0a43e74ad8cc353a71ac03a0ce
+DIST List-MoreUtils-0.426.tar.gz 145518 SHA256 8e05610d04c6d0cdb63607d88950fd5c6e850a71cea1e1138ebf5c26c83a47b6 SHA512 622ce2e5e418ba803359107b15cc9f5234bfbb32f03d072c0b448b6b8d603472254d9653757d0048f537852a68b17bef1b71a7f5104d95802e4b78f595664b32 WHIRLPOOL d9156ba0f34706358758ba9eba8ad0f7ed45ac091fde7ae51c47f7fcb737ab0ce034ee8302cde1bcbeb9255b763d9ab6c211f73b483168e6f2e86c4088f5f779
diff --git a/dev-perl/List-MoreUtils/files/List-MoreUtils-0.426.0-xs-config.patch b/dev-perl/List-MoreUtils/files/List-MoreUtils-0.426.0-xs-config.patch
new file mode 100644
index 000000000000..941f2d6bc1a1
--- /dev/null
+++ b/dev-perl/List-MoreUtils/files/List-MoreUtils-0.426.0-xs-config.patch
@@ -0,0 +1,78 @@
+From 903ed372cad330e86ef767eb98a4d29d04781e5e Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 28 Oct 2017 14:53:23 +1300
+Subject: Use configuration instead of pure discovery for XS Support
+
+Given in Gentoo that ::XS is either going to be available, or not,
+based on user configuration, *before* configure runs, trying to turn
+it on/off in configure is nonsense.
+
+Subsequently, this test logic just determines if we should be running
+the XS tests or not.
+
+If ::XS is installed already, then XS tests should be run despite user
+not opting in to XS, as the opt-in only regulates dependencies, but
+LMU can still trigger ::XS at runtime.
+
+If the user opts in to XS, then the tests should be run regardless of
+perl detecting XS being installed, because XS *NOT* being available
+is then an error.
+---
+ Makefile.PL | 41 ++---------------------------------------
+ 1 file changed, 2 insertions(+), 39 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 89680b1..5083b86 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -8,45 +8,8 @@ use 5.008_001;
+ use Config;
+ use ExtUtils::MakeMaker;
+
+-BEGIN
+-{
+- unless (grep { $_ eq "." } @INC)
+- {
+- use lib ".";
+- }
+-}
+-
+-use inc::latest 'Capture::Tiny';
+-use inc::latest 'Config::AutoConf';
+-
+-if (inc::latest->can("write"))
+-{
+- inc::latest->write("inc");
+- for my $mod (inc::latest->loaded_modules)
+- {
+- inc::latest->bundle_module($mod, "inc");
+- }
+-}
+-
+-use inc::Config::AutoConf::LMU ();
+-
+-inc::Config::AutoConf::LMU->_set_argv(@ARGV); # XXX hack because we cannot construct for global use
+-my $loadable_xs = inc::Config::AutoConf::LMU->check_produce_loadable_xs_build();
+-
+-if (-d "Sandbox")
+-{
+- unless (grep { $_ eq "." } @INC)
+- {
+- use lib ".";
+- }
+- eval "use Sandbox::Tumble ();";
+- $@ and die $@;
+- eval "use File::Path ();";
+- File::Path->import;
+- -d 't/xs' and rmtree('t/xs');
+- -d 't/pureperl' and rmtree('t/pureperl');
+- Sandbox::Tumble->tumble(qw(t));
+-}
++my $loadable_xs = $ENV{LMU_USE_XS} ||
++ eval { require List::MoreUtils::XS; List::MoreUtils::XS->VERSION(0.426) };
+
+ my $conflictMsg = <<EOCM;
+ ***
+--
+2.14.3
+