summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-09-25 21:33:15 +0200
committerJeroen Roovers <jer@gentoo.org>2016-09-25 21:43:43 +0200
commitfc093b700face76248b696cf1558581455ad4777 (patch)
tree13a310e443a84489b4d0e22a69e62db73d30ffee
parentkde-plasma: remove 5.7.4 (diff)
downloadgentoo-fc093b700face76248b696cf1558581455ad4777.tar.gz
gentoo-fc093b700face76248b696cf1558581455ad4777.tar.bz2
gentoo-fc093b700face76248b696cf1558581455ad4777.zip
app-admin/lsyncd: Install man page in the right place.
Package-Manager: portage-2.3.1
-rw-r--r--app-admin/lsyncd/files/lsyncd-2.1.6-mandir.patch8
-rw-r--r--app-admin/lsyncd/lsyncd-2.1.6-r1.ebuild29
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/lsyncd/files/lsyncd-2.1.6-mandir.patch b/app-admin/lsyncd/files/lsyncd-2.1.6-mandir.patch
new file mode 100644
index 000000000000..c78df89b694b
--- /dev/null
+++ b/app-admin/lsyncd/files/lsyncd-2.1.6-mandir.patch
@@ -0,0 +1,8 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -92,4 +92,4 @@
+ target_link_libraries( lsyncd ${LUA_LIBRARIES} )
+
+ install( TARGETS lsyncd RUNTIME DESTINATION bin )
+-install( FILES doc/lsyncd.1 DESTINATION man)
++install( FILES doc/lsyncd.1 DESTINATION share/man/man1)
diff --git a/app-admin/lsyncd/lsyncd-2.1.6-r1.ebuild b/app-admin/lsyncd/lsyncd-2.1.6-r1.ebuild
new file mode 100644
index 000000000000..d8152bfbb0b2
--- /dev/null
+++ b/app-admin/lsyncd/lsyncd-2.1.6-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_IN_SOURCE_BUILD="YES_PLEASE_OMG"
+inherit cmake-utils
+
+DESCRIPTION="Live Syncing (Mirror) Daemon"
+HOMEPAGE="https://github.com/axkibe/lsyncd"
+SRC_URI="https://github.com/axkibe/lsyncd/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+
+CDEPEND=">=dev-lang/lua-5.1[deprecated]"
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ net-misc/rsync"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-mandir.patch
+)
+
+S=${WORKDIR}/${PN}-release-${PV}