summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2016-06-29 12:52:02 +0200
committerNicolas Bock <nicolasbock@gentoo.org>2016-06-29 12:53:16 +0200
commitfc3767361acb4434090c4f1f234762fac78dffb5 (patch)
treeb76c6f7b30a1477759fba1f842d177d5af4bd2d2
parentdev-python/webencodings: Bump (diff)
downloadgentoo-fc3767361acb4434090c4f1f234762fac78dffb5.tar.gz
gentoo-fc3767361acb4434090c4f1f234762fac78dffb5.tar.bz2
gentoo-fc3767361acb4434090c4f1f234762fac78dffb5.zip
dev-vcs/git-deps: New ebuild
Package-Manager: portage-2.2.28
-rw-r--r--dev-vcs/git-deps/git-deps-9999.ebuild29
-rw-r--r--dev-vcs/git-deps/metadata.xml8
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-vcs/git-deps/git-deps-9999.ebuild b/dev-vcs/git-deps/git-deps-9999.ebuild
new file mode 100644
index 000000000000..d8c27befa8b5
--- /dev/null
+++ b/dev-vcs/git-deps/git-deps-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/aspiers/git-deps"
+EGIT_BRANCH=master
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit git-r3 python-r1
+
+DESCRIPTION="git commit dependency analysis tool"
+HOMEPAGE="https://github.com/aspiers/git-deps"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pygit2
+ ${PYTHON_DEPS}
+ "
+DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_install() {
+ python_foreach_impl python_newexe git-deps.py git-deps
+}
diff --git a/dev-vcs/git-deps/metadata.xml b/dev-vcs/git-deps/metadata.xml
new file mode 100644
index 000000000000..1ebfceec0bca
--- /dev/null
+++ b/dev-vcs/git-deps/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ git-deps is a tool for performing automatic analysis of dependencies
+ between commits in a git repository.
+ </longdescription>
+</pkgmetadata>