summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-04-16 21:10:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-04-16 21:50:24 +0200
commitfc82d40dd02c48e5521b896a7f2be32c47a44101 (patch)
treecd94aa0ee00fe295d3c929a2e06d42554c3f5fb4
parentkde-plasma/kscreenlocker: add 6.0.4 (diff)
downloadgentoo-fc82d40dd02c48e5521b896a7f2be32c47a44101.tar.gz
gentoo-fc82d40dd02c48e5521b896a7f2be32c47a44101.tar.bz2
gentoo-fc82d40dd02c48e5521b896a7f2be32c47a44101.zip
kde-plasma/ksshaskpass: add 6.0.4
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-6.0.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 3d5dc972159e..2aeff2f1d1a5 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.27.11.tar.xz 27980 BLAKE2B 4fa35480f0ed7389bf41f56fc8266fccb8a33060c37f6df2c1edc44f49466267dbd45584e0afff6aaa79a3b5ffc1aca916c36a7ad768e36a457c081bfa53f217 SHA512 85c4091faa4ec4a6d068d4a0d464601054b88187ccfa05f4156b146dd3b3900dc15bcb3f9f9b0b057fb9b5687eabf55bb34d06d98a9e26ddb6a0afba1684feee
DIST ksshaskpass-6.0.3.tar.xz 28860 BLAKE2B 819aee1d7061803f3de668d4fbdd0f7c3dd8ac4d083262c97ff1fb3a09925f8f552226c7b4908f660be6b781791bbcb4db8e5c7ddd3e96110f07059a8b34f9e8 SHA512 7d665cb47b762515007d6251534d1d60a54fc26fdc32f8849de36d55d604417682242f8acbb9395d0831ced784a8a0368188fee9b0201dbb9bf2d2f21a03db43
+DIST ksshaskpass-6.0.4.tar.xz 28864 BLAKE2B a43470fb0f90887075bae2ad22c7bded179e225e3b0613dd2dc8717b997781f5253fed4daa7cb44cc8c351e34001b96913b52c6aab6fb6df9603b73da5c2bb05 SHA512 a0dc562f0fa7cb8cc17e84745b29f82e96828e8a093e5b2a89a13924685649ecd62b41d937a3a39c9a9309db90ee427c5b4bea94a2b79e564d065d13e4ebe6b4
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-6.0.4.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-6.0.4.ebuild
new file mode 100644
index 000000000000..8bd4b1f19279
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-6.0.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.0
+QTMIN=6.6.2
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 6,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 6 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+}