summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-10-24 09:08:36 +0200
committerHans de Graaff <graaff@gentoo.org>2015-10-24 09:08:36 +0200
commitfccfe881c97dd8279384cb636f9f8b8a046c86ed (patch)
treec4493ba1e5c22636bf01bfa50acc9e98262fcdeb
parentdev-ruby/rdoc: make sure rdoc exists, bug 562980 (diff)
downloadgentoo-fccfe881c97dd8279384cb636f9f8b8a046c86ed.tar.gz
gentoo-fccfe881c97dd8279384cb636f9f8b8a046c86ed.tar.bz2
gentoo-fccfe881c97dd8279384cb636f9f8b8a046c86ed.zip
dev-ruby/celluloid: fix timers dependency for slotting, bug 563018
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-ruby/celluloid/celluloid-0.16.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/celluloid/celluloid-0.16.0-r1.ebuild b/dev-ruby/celluloid/celluloid-0.16.0-r1.ebuild
new file mode 100644
index 000000000000..065037b83264
--- /dev/null
+++ b/dev-ruby/celluloid/celluloid-0.16.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# rbx or jruby recommended, but only in 1.9 mode.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+#Needed by dev-ruby/listen
+RUBY_FAKEGEM_EXTRAINSTALL="spec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Celluloid provides a simple and natural way to build fault-tolerant concurrent programs in Ruby"
+HOMEPAGE="https://github.com/celluloid/celluloid"
+SRC_URI="https://github.com/celluloid/celluloid/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RUBY_PATCHES=( "${P}-call-private-methods.patch" )
+
+ruby_add_rdepend ">=dev-ruby/timers-4.0.0:4"
+
+all_ruby_prepare() {
+ rm Gemfile .rspec || die
+
+ sed -i -e '/[Bb]undler/d' -e '/coveralls/I s:^:#:' spec/spec_helper.rb || die
+
+ # Force loading of the correct timers slot to avoid a bundler dependency.
+ sed -i -e '3igem "timers", "~>4.0"' spec/spec_helper.rb || die
+
+ # Adjust timers dependency to match our slots, bug 563018
+ sed -i -e '/timers/ s/4.0.0/4.0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}