summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-01 10:03:13 +0000
committerSam James <sam@gentoo.org>2021-06-01 10:08:05 +0000
commitfd06875ba08ab7f517e51e7c4277fc6f84b3a15c (patch)
tree749362427067f67bbdc5921e8a8a3dbcce4cb413
parentapp-portage/gs-elpa: add Python 3.9 (diff)
downloadgentoo-fd06875ba08ab7f517e51e7c4277fc6f84b3a15c.tar.gz
gentoo-fd06875ba08ab7f517e51e7c4277fc6f84b3a15c.tar.bz2
gentoo-fd06875ba08ab7f517e51e7c4277fc6f84b3a15c.zip
app-backup/borgweb: add Python 3.9
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-backup/borgweb/borgweb-0.2.0-r2.ebuild6
-rw-r--r--app-backup/borgweb/borgweb-0.3.0.ebuild6
2 files changed, 4 insertions, 8 deletions
diff --git a/app-backup/borgweb/borgweb-0.2.0-r2.ebuild b/app-backup/borgweb/borgweb-0.2.0-r2.ebuild
index 08800aaccdd9..6ed8f90906be 100644
--- a/app-backup/borgweb/borgweb-0.2.0-r2.ebuild
+++ b/app-backup/borgweb/borgweb-0.2.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
@@ -14,8 +14,6 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="app-backup/borgbackup[${PYTHON_USEDEP}]
dev-python/flask[${PYTHON_USEDEP}]"
diff --git a/app-backup/borgweb/borgweb-0.3.0.ebuild b/app-backup/borgweb/borgweb-0.3.0.ebuild
index 08800aaccdd9..6ed8f90906be 100644
--- a/app-backup/borgweb/borgweb-0.3.0.ebuild
+++ b/app-backup/borgweb/borgweb-0.3.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
@@ -14,8 +14,6 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="app-backup/borgbackup[${PYTHON_USEDEP}]
dev-python/flask[${PYTHON_USEDEP}]"