summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-06-13 11:22:42 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-06-13 11:30:25 +0200
commitfdbacd407eb7482df2e52d2232b97daae639d8bc (patch)
treef9d34b568dd89cac55cafc5f039f67797ad8d8a5
parentprofiles: mask xindy and tex4ht for removal (diff)
downloadgentoo-fdbacd407eb7482df2e52d2232b97daae639d8bc.tar.gz
gentoo-fdbacd407eb7482df2e52d2232b97daae639d8bc.tar.bz2
gentoo-fdbacd407eb7482df2e52d2232b97daae639d8bc.zip
net-misc/owncloud-client: 2.6.3 bump
Also fixes compilation with qt 5.15 Closes: https://bugs.gentoo.org/726172 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--net-misc/owncloud-client/Manifest1
-rw-r--r--net-misc/owncloud-client/files/owncloud-client-2.6.3.14058-qt515.patch11
-rw-r--r--net-misc/owncloud-client/owncloud-client-2.6.3.14058.ebuild85
3 files changed, 97 insertions, 0 deletions
diff --git a/net-misc/owncloud-client/Manifest b/net-misc/owncloud-client/Manifest
index 61d9950b6d18..998b413cbb0c 100644
--- a/net-misc/owncloud-client/Manifest
+++ b/net-misc/owncloud-client/Manifest
@@ -1,2 +1,3 @@
DIST owncloudclient-2.6.0.13018.tar.xz 17311396 BLAKE2B b0c76b2fea51ca9e71f918ada2b99ce20b9b62494c41608e804c4ca0c8aafe59897fea31d28bed1ec61feefca4b4b6e783c6fa777ea56524e7c18d1a460ab954 SHA512 b8eb9dc6f9c061a74fee3f31926a3fb7f5093277955fe327d1169c84f929d1e1ad8da472a7098c1c10399f395c6bfc3b2684cf4c85cddc5e45b733abfb8e4046
DIST owncloudclient-2.6.1.13407.tar.xz 17317284 BLAKE2B b88bfc987aca036b6269e094cee5b91a3516db7b899df4cfde4961ba6eb3bb24329de103b154f0a21e5778997659cfb9b53be2f88affe03251aa9c747276d517 SHA512 40e0b607ac6cd5437682cd40e125404472c5ad63520e1dde19729760c0b7612451b3a34ede74e988d8fd09a6fae7d17a3dd6c5b0cfa6563dab7245e5f67c52bf
+DIST owncloudclient-2.6.3.14058.tar.xz 21246672 BLAKE2B 15b75c2162d22c22827a057242d783e739837f618c2f65be3edce6b2678aaa13505fd14c4e4088374c240537a999d9aff7758ccb93993e0cbdebb886f735311c SHA512 e2159dc5668f263449e7a9a20ef10c6bb140ea5bd1128a6d3438abce03bc4913bb4eecbacc5160c8018398b6fa75ccfb2a9ab9ad637965e41caebc83994b80b3
diff --git a/net-misc/owncloud-client/files/owncloud-client-2.6.3.14058-qt515.patch b/net-misc/owncloud-client/files/owncloud-client-2.6.3.14058-qt515.patch
new file mode 100644
index 000000000000..57dd20938fc0
--- /dev/null
+++ b/net-misc/owncloud-client/files/owncloud-client-2.6.3.14058-qt515.patch
@@ -0,0 +1,11 @@
+diff -Naur owncloudclient-2.6.3.14058.orig/src/libsync/networkjobs.cpp owncloudclient-2.6.3.14058/src/libsync/networkjobs.cpp
+--- owncloudclient-2.6.3.14058.orig/src/libsync/networkjobs.cpp 2020-06-12 14:35:04.000000000 +0200
++++ owncloudclient-2.6.3.14058/src/libsync/networkjobs.cpp 2020-06-13 11:18:28.822842347 +0200
+@@ -31,6 +31,7 @@
+ #include <QJsonObject>
+ #ifndef TOKEN_AUTH_ONLY
+ #include <QPainter>
++#include <QPainterPath>
+ #endif
+
+ #include "networkjobs.h"
diff --git a/net-misc/owncloud-client/owncloud-client-2.6.3.14058.ebuild b/net-misc/owncloud-client/owncloud-client-2.6.3.14058.ebuild
new file mode 100644
index 000000000000..d7df80536b71
--- /dev/null
+++ b/net-misc/owncloud-client/owncloud-client-2.6.3.14058.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg
+
+DESCRIPTION="Synchronize files from ownCloud Server with your computer"
+HOMEPAGE="https://owncloud.org/"
+SRC_URI="https://download.owncloud.com/desktop/stable/${P/-}.tar.xz"
+
+LICENSE="CC-BY-3.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc dolphin gnome-keyring nautilus test"
+
+COMMON_DEPEND=">=dev-db/sqlite-3.4:3
+ dev-libs/qtkeychain[gnome-keyring?,qt5(+)]
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-fs/inotify-tools
+ dolphin? (
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/kio:5
+ )
+ nautilus? ( dev-python/nautilus-python )"
+
+RDEPEND="${COMMON_DEPEND}"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/linguist-tools:5
+ doc? (
+ dev-python/sphinx
+ dev-tex/latexmk
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ )
+ dolphin? ( kde-frameworks/extra-cmake-modules )
+ test? (
+ dev-util/cmocka
+ dev-qt/qttest:5
+ )"
+
+RESTRICT="!test? ( test )"
+
+S=${WORKDIR}/${P/-}
+
+PATCHES=( "${FILESDIR}"/${P}-qt515.patch )
+
+src_prepare() {
+ # Keep tests in ${T}
+ sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die
+
+ if ! use nautilus; then
+ pushd shell_integration > /dev/null || die
+ cmake_comment_add_subdirectory nautilus
+ popd > /dev/null || die
+ fi
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DCMAKE_DISABLE_FIND_PACKAGE_Sphinx=$(usex !doc)
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5=$(usex !dolphin)
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if ! use doc ; then
+ elog "Documentation and man pages not installed"
+ elog "Enable doc USE-flag to generate them"
+ fi
+ xdg_pkg_postinst
+}