summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-12-26 21:33:30 -0500
committerAnthony G. Basile <blueness@gentoo.org>2015-12-26 21:34:09 -0500
commitfeab38839dca251c536c53a914531a0c63571b0a (patch)
tree75e4a8b382503dda049e0137f70604118029b034
parentwww-plugins/freshplayerplugin: Version bump (diff)
downloadgentoo-feab38839dca251c536c53a914531a0c63571b0a.tar.gz
gentoo-feab38839dca251c536c53a914531a0c63571b0a.tar.bz2
gentoo-feab38839dca251c536c53a914531a0c63571b0a.zip
app-backup/attic: initial commit
Package-Manager: portage-2.2.24
-rw-r--r--app-backup/attic/Manifest1
-rw-r--r--app-backup/attic/attic-0.16.ebuild33
-rw-r--r--app-backup/attic/attic-9999.ebuild33
-rw-r--r--app-backup/attic/metadata.xml8
4 files changed, 75 insertions, 0 deletions
diff --git a/app-backup/attic/Manifest b/app-backup/attic/Manifest
new file mode 100644
index 000000000000..1f5d62363ed1
--- /dev/null
+++ b/app-backup/attic/Manifest
@@ -0,0 +1 @@
+DIST attic-0.16.tar.gz 87985 SHA256 ce44800b08540cbe334f0a4f5da49585850c1eea1bf621c2766bbdcc98a13e09 SHA512 16139cd93bff59414cc1ce3fd68e2dd0aed4937a20bd1003880961ad2e239a1e982fd0d4f6b791165464213b88dea6ccd8e5e59d2087809be2e1bfdfd3b3186c WHIRLPOOL e3f0963cca0ede9d5400393cb5aabf66433c87bbc0dd997e2d63991e69d380113c6a25075ecac0ab61e5807676bf2aa87e72257133df0f2ee879ccaef586e5a3
diff --git a/app-backup/attic/attic-0.16.ebuild b/app-backup/attic/attic-0.16.ebuild
new file mode 100644
index 000000000000..b3249988f1c9
--- /dev/null
+++ b/app-backup/attic/attic-0.16.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jborg/attic.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jborg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Attic is a deduplicating backup program written in Python."
+HOMEPAGE="https://attic-backup.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="libressl"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ dev-python/llfuse[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"
diff --git a/app-backup/attic/attic-9999.ebuild b/app-backup/attic/attic-9999.ebuild
new file mode 100644
index 000000000000..b3249988f1c9
--- /dev/null
+++ b/app-backup/attic/attic-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jborg/attic.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jborg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Attic is a deduplicating backup program written in Python."
+HOMEPAGE="https://attic-backup.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="libressl"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ dev-python/llfuse[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"
diff --git a/app-backup/attic/metadata.xml b/app-backup/attic/metadata.xml
new file mode 100644
index 000000000000..1e7587374fdf
--- /dev/null
+++ b/app-backup/attic/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+</pkgmetadata>