summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-10-10 19:58:45 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-10-10 19:58:45 -0400
commitff02222b54ba69ec956390dbdde7363c883ba038 (patch)
tree4117e38f00abfe28978ce36cf362752d2a8f8be5
parentmail-client/nail: add libressl support (diff)
downloadgentoo-ff02222b54ba69ec956390dbdde7363c883ba038.tar.gz
gentoo-ff02222b54ba69ec956390dbdde7363c883ba038.tar.bz2
gentoo-ff02222b54ba69ec956390dbdde7363c883ba038.zip
mail-client/sylpheed: add libressl support
Package-Manager: portage-2.2.20.1
-rw-r--r--mail-client/sylpheed/sylpheed-3.4.3-r1.ebuild63
-rw-r--r--mail-client/sylpheed/sylpheed-3.4.3.ebuild2
2 files changed, 64 insertions, 1 deletions
diff --git a/mail-client/sylpheed/sylpheed-3.4.3-r1.ebuild b/mail-client/sylpheed/sylpheed-3.4.3-r1.ebuild
new file mode 100644
index 000000000000..febe5932947c
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-3.4.3-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://${PN}.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt ipv6 ldap libressl nls oniguruma pda spell ssl xface"
+
+CDEPEND="x11-libs/gtk+:2
+ crypt? ( app-crypt/gpgme )
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ oniguruma? ( dev-libs/oniguruma )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell:2 )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )"
+RDEPEND="${CDEPEND}
+ app-misc/mime-types
+ net-misc/curl"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ xface? ( media-libs/compface )"
+
+src_configure() {
+ local htmldir=/usr/share/doc/${PF}/html
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable oniguruma) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
+ --disable-updatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog* NEWS* PLUGIN* README* TODO*
+
+ doicon *.png
+ domenu *.desktop
+
+ cd plugin/attachment_tool
+ docinto plugin/attachment_tool
+ emake DESTDIR="${D}" install-plugin
+ dodoc README
+}
diff --git a/mail-client/sylpheed/sylpheed-3.4.3.ebuild b/mail-client/sylpheed/sylpheed-3.4.3.ebuild
index 5bd6d3803ee5..1b53b30d7e68 100644
--- a/mail-client/sylpheed/sylpheed-3.4.3.ebuild
+++ b/mail-client/sylpheed/sylpheed-3.4.3.ebuild
@@ -22,7 +22,7 @@ CDEPEND="x11-libs/gtk+:2
oniguruma? ( dev-libs/oniguruma )
pda? ( app-pda/jpilot )
spell? ( app-text/gtkspell:2 )
- ssl? ( dev-libs/openssl )"
+ ssl? ( dev-libs/openssl:0 )"
RDEPEND="${CDEPEND}
app-misc/mime-types
net-misc/curl"