summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-05-07 12:39:50 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-05-08 08:20:37 -0400
commitff64a19e56dfc971e4feea4ab86c36c1651c7340 (patch)
treee179c3ef5af344c01d5053dec8f1057ffbca35d1
parentsci-libs/coinor-vol: add an "<upstream>" tag to metadata.xml. (diff)
downloadgentoo-ff64a19e56dfc971e4feea4ab86c36c1651c7340.tar.gz
gentoo-ff64a19e56dfc971e4feea4ab86c36c1651c7340.tar.bz2
gentoo-ff64a19e56dfc971e4feea4ab86c36c1651c7340.zip
sci-libs/coinor-vol: new EAPI=7 version 1.5.4.
A standard version/EAPI bump, with the usual coinor-* weirdness now somewhat documented. Portage is complaining about the precompressed example data, but I think that's a portage problem since I've explicitly excluded it with "docompress -x". Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-libs/coinor-vol/Manifest2
-rw-r--r--sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild68
-rw-r--r--sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild82
3 files changed, 83 insertions, 69 deletions
diff --git a/sci-libs/coinor-vol/Manifest b/sci-libs/coinor-vol/Manifest
index e0e1c257f502..d3fe7651453c 100644
--- a/sci-libs/coinor-vol/Manifest
+++ b/sci-libs/coinor-vol/Manifest
@@ -1 +1 @@
-DIST Vol-1.4.4.tgz 3205621 BLAKE2B 187b8522d6fbcc287e3eb63e00553d2f90bb7c9add17e2ed604cef3e2ab2ba214a0d6e27ecd28457a983d0d11193ba31914f5defd841848fb9c2486d80ca4935 SHA512 20e04efac09694ddfa035496ec9b2920ef702e5a2ec4515cd88c52129c783efd3c25e044e6c2cec67ad800b297ebd03f3c3c377f58829790109d8d6dcb40cc39
+DIST coinor-vol-1.5.4.tar.gz 983625 BLAKE2B b1c78f94d1232d773aa325227ac01ad469d3ff56571119ae95ddb9a34eb7d55d004111e81dc89bb4bae1b5754da29cd4e93983772e158afa131a4da0b187b03c SHA512 ba489b909dab45a9a48a32804a571fc9ad966b268ce8a81a391a743b523bce393bd649aaf15c51f401267fe05fb2ff7623a1f7208c0b9d6c24af9b659a230780
diff --git a/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild b/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild
deleted file mode 100644
index ea1df608c973..000000000000
--- a/sci-libs/coinor-vol/coinor-vol-1.4.4.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools-utils multilib
-
-MYPN=Vol
-
-DESCRIPTION="COIN-OR Volume algorithm linear programming solver"
-HOMEPAGE="https://projects.coin-or.org/Vol"
-SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
-
-LICENSE="EPL-1.0"
-SLOT="0/1"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- sci-libs/coinor-osi:=
- sci-libs/coinor-utils:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen[dot] )
- test? ( sci-libs/coinor-sample )"
-
-S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
-
-src_prepare() {
- # needed for the --with-coin-instdir
- dodir /usr
- sed -i \
- -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
- configure || die
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- --enable-dependency-linking
- --with-coin-instdir="${ED}"/usr
- $(use_with doc dot)
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- # hack for parallel build, to overcome not patching Makefile.am above
- autotools-utils_src_compile -C src libVol.la
- autotools-utils_src_compile all $(usex doc doxydoc "")
-}
-
-src_test() {
- autotools-utils_src_test test
-}
-
-src_install() {
- use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
- autotools-utils_src_install -C src install-am
- autotools-utils_src_install
- # already installed
- rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild b/sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild
new file mode 100644
index 000000000000..53276b0f38c4
--- /dev/null
+++ b/sci-libs/coinor-vol/coinor-vol-1.5.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=Vol
+
+DESCRIPTION="COIN-OR volume algorithm linear program solver"
+HOMEPAGE="https://github.com/coin-or/Vol/"
+SRC_URI="https://github.com/coin-or/${MY_PN}/archive/releases/${PV}.tar.gz
+ -> ${P}.tar.gz"
+LICENSE="EPL-1.0"
+
+# major soname component
+SLOT="0/1"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+RESTRICT="!test? ( test )"
+
+# Fortran is NOT needed, but the ./configure scripts for all of the CoinOR
+# packages contain a check for it. Gentoo bug 601648 and upstream issue,
+#
+# https://github.com/coin-or/CoinUtils/issues/132
+#
+BDEPEND="virtual/fortran
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+DEPEND="sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-releases-${PV}/${MY_PN}"
+
+src_prepare() {
+ # Needed to make the --with-coin-instdir in src_configure happy.
+ dodir /usr
+
+ # They don't need to guess at this, but they do, and get it wrong...
+ sed -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ -i configure \
+ || die "failed to fix the pkgconfig path in ${S}/configure"
+
+ default
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}/usr"
+ $(use_with doc dot)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake all $(usex doc doxydoc "")
+}
+
+src_test() {
+ # NOT redundant! The build system has a "make check" target that does
+ # nothing, so if you don't specify "test" here, you'll get a no-op.
+ emake test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${BUILD_DIR}/doxydocs/html/")
+
+ emake DESTDIR="${D}" install
+
+ # Duplicate junk, and in the wrong location.
+ rm -r "${ED}/usr/share/coin/doc/${MY_PN}" || die
+
+ # Portage still throws a warning for these, but it's a bug
+ # as far as I can tell: https://bugs.gentoo.org/721516
+ docompress -x "/usr/share/doc/${PF}/examples/Volume-LP/data.mps.gz"
+ docompress -x "/usr/share/doc/${PF}/examples/VolUfl/data.gz"
+ use examples && dodoc -r examples
+}