summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-31 15:33:03 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-31 15:34:54 +0200
commitffd2f6bdc0b43cc9f83242d526d6850bbadd7d26 (patch)
tree5f3dd28341fef07e9d05ed56bc1138340b3f861a
parentros-meta/navigation: Bump to 1.16.1. (diff)
downloadgentoo-ffd2f6bdc0b43cc9f83242d526d6850bbadd7d26.tar.gz
gentoo-ffd2f6bdc0b43cc9f83242d526d6850bbadd7d26.tar.bz2
gentoo-ffd2f6bdc0b43cc9f83242d526d6850bbadd7d26.zip
app-portage/smart-live-rebuild: Bump to 1.3.6
-rw-r--r--app-portage/smart-live-rebuild/Manifest1
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-portage/smart-live-rebuild/Manifest b/app-portage/smart-live-rebuild/Manifest
index 8adebff45125..974fcb6a784c 100644
--- a/app-portage/smart-live-rebuild/Manifest
+++ b/app-portage/smart-live-rebuild/Manifest
@@ -1 +1,2 @@
DIST smart-live-rebuild-1.3.5.tar.bz2 16004 BLAKE2B fa1fcb13c739ef15b343de3460b029a311a4c08be3ec44ff5c0c89fef4d07fde7fa5558444b25ce234d64b03465b4a401593600f3fec5cbbfba76bdc76fcca34 SHA512 46933334c8c46a056c837e60a5d8aed30a35b1ddd20d7c0f03e813f6cac11cc2dc9469674b1e9c23d94c9ebc474e5eacc7aa0e8f82492554a7f49b438ed740d2
+DIST smart-live-rebuild-1.3.6.tar.gz 17194 BLAKE2B a1c4f07e66ce3328ae70f88d086c33875bed68aea645a180e68fbd997051c6d398c1133d8e9c72378741fe41c519e941e76dc25d9c3f9c61c36531fe6fbe8e79 SHA512 f9fe57269654d69c3b21d0b6e378dfa3d2c00e67dae44278b2b81d631e4645346ecaeb5c9f43b77d39312b97edee247ba8b05303be903d6a3573bc226159c40f
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6.ebuild
new file mode 100644
index 000000000000..9e516f44532a
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
+SRC_URI="https://github.com/mgorny/smart-live-rebuild/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+# Tests need to be fixed
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example smart-live-rebuild.conf
+}