summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-19 16:23:55 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-19 16:24:14 -0600
commit95d3b6272119ad510a6988e1662727d50d3b7d6c (patch)
treec1fac2e7a0b78c50365b54a71168f830a281531c /acct-user/puppetdb/puppetdb-0.ebuild
parentacct-user/puppet: add puppet user (diff)
downloadgentoo-95d3b6272119ad510a6988e1662727d50d3b7d6c.tar.gz
gentoo-95d3b6272119ad510a6988e1662727d50d3b7d6c.tar.bz2
gentoo-95d3b6272119ad510a6988e1662727d50d3b7d6c.zip
acct-user/puppetdb: add puppetdb user
Package-Manager: Portage-2.3.84, Repoman-2.3.20 RepoMan-Options: --force Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'acct-user/puppetdb/puppetdb-0.ebuild')
-rw-r--r--acct-user/puppetdb/puppetdb-0.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/acct-user/puppetdb/puppetdb-0.ebuild b/acct-user/puppetdb/puppetdb-0.ebuild
new file mode 100644
index 000000000000..7f70113f6559
--- /dev/null
+++ b/acct-user/puppetdb/puppetdb-0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="User for the puppetdb service"
+ACCT_USER_ID=456
+ACCT_USER_HOME=/opt/puppetlabs/server/data/puppetserver
+ACCT_USER_HOME_PERMS=0770
+ACCT_USER_GROUPS=( puppetdb )
+
+acct-user_add_deps