summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-19 17:36:44 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-19 17:52:44 +0200
commit15e496907e00fb300a59dbfe7a60b09fed254098 (patch)
tree1206337193ad9568819065cc7a92f89ff10f44ba /acct-user
parentacct-group/monkeysphere: new group for app-crypt/monkeysphere, GID 390 (diff)
downloadgentoo-15e496907e00fb300a59dbfe7a60b09fed254098.tar.gz
gentoo-15e496907e00fb300a59dbfe7a60b09fed254098.tar.bz2
gentoo-15e496907e00fb300a59dbfe7a60b09fed254098.zip
acct-user/monkeysphere: new user for app-crypt/monkeysphere, UID 390
Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'acct-user')
-rw-r--r--acct-user/monkeysphere/metadata.xml8
-rw-r--r--acct-user/monkeysphere/monkeysphere-0.ebuild16
2 files changed, 24 insertions, 0 deletions
diff --git a/acct-user/monkeysphere/metadata.xml b/acct-user/monkeysphere/metadata.xml
new file mode 100644
index 000000000000..91439c59951d
--- /dev/null
+++ b/acct-user/monkeysphere/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>k_f@gentoo.org</email>
+ <name>Kristian Fiskerstrand</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/acct-user/monkeysphere/monkeysphere-0.ebuild b/acct-user/monkeysphere/monkeysphere-0.ebuild
new file mode 100644
index 000000000000..a4288b053b5a
--- /dev/null
+++ b/acct-user/monkeysphere/monkeysphere-0.ebuild
@@ -0,0 +1,16 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="monkeysphere program user"
+
+ACCT_USER_ID=390
+ACCT_USER_HOME="/var/lib/${PN}"
+ACCT_USER_HOME_OWNER="root:${PN}"
+ACCT_USER_HOME_PERMS=0751
+ACCT_USER_GROUPS=( ${PN} )
+
+acct-user_add_deps