summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2020-01-21 06:34:21 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-05-11 17:22:47 +0300
commit8138c6f155179dcd5e850effbedcc08816157a5b (patch)
tree98f2095a9bdf8e6a3ccbcde8afe66dccff749465 /acct-user
parentacct-group/spamd: create for spamassassin (diff)
downloadgentoo-8138c6f155179dcd5e850effbedcc08816157a5b.tar.gz
gentoo-8138c6f155179dcd5e850effbedcc08816157a5b.tar.bz2
gentoo-8138c6f155179dcd5e850effbedcc08816157a5b.zip
acct-user/spamd: create for spamassassin
Needed for mail-filter/spamassassin GLEP-81 compliance. See-Also: https://github.com/gentoo/gentoo/pull/14055/ Package-Manager: Portage-2.3.84, Repoman-2.3.16 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'acct-user')
-rw-r--r--acct-user/spamd/metadata.xml13
-rw-r--r--acct-user/spamd/spamd-0.ebuild25
2 files changed, 38 insertions, 0 deletions
diff --git a/acct-user/spamd/metadata.xml b/acct-user/spamd/metadata.xml
new file mode 100644
index 000000000000..265493eecbee
--- /dev/null
+++ b/acct-user/spamd/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo_bugs_peep@parallaxshift.com</email>
+ <name>Philippe Chaintreuil</name>
+ </maintainer>
+
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/acct-user/spamd/spamd-0.ebuild b/acct-user/spamd/spamd-0.ebuild
new file mode 100644
index 000000000000..e4fcb0a0378a
--- /dev/null
+++ b/acct-user/spamd/spamd-0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="User for the SpamAssassin daemon"
+
+ACCT_USER_ID=337
+ACCT_USER_GROUPS=( "${PN}" )
+# The spamd daemon runs as this user. Use a real home directory so
+# that it can hold SA configuration.
+#
+# Since spamd's home contains user-modifiable config files, it's
+# a violation of the Linux FHS for it to be here, but it's been
+# decided it can't be in /home/.
+#
+# - https://github.com/gentoo/gentoo/pull/14055#issuecomment-582929503
+# - https://archives.gentoo.org/gentoo-dev/message/790294f7a46496aecd0056289c4b6d08
+#
+ACCT_USER_HOME="/var/lib/spamd"
+ACCT_USER_HOME_PERMS=0700
+
+acct-user_add_deps