summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-18 02:31:11 +0100
committerSam James <sam@gentoo.org>2022-08-18 04:09:55 +0100
commit09b3a728f077679df68431188a5bf7f35d595b1b (patch)
tree042e0711dbd84932c29618edb121eaad483d1527 /app-accessibility/emacspeak
parentapp-accessibility/emacspeak: add github upstream metadata (diff)
downloadgentoo-09b3a728f077679df68431188a5bf7f35d595b1b.tar.gz
gentoo-09b3a728f077679df68431188a5bf7f35d595b1b.tar.bz2
gentoo-09b3a728f077679df68431188a5bf7f35d595b1b.zip
app-accessibility/emacspeak: add 56.0
Bug: https://bugs.gentoo.org/622166 Closes: https://bugs.gentoo.org/835097 Closes: https://bugs.gentoo.org/832135 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-accessibility/emacspeak')
-rw-r--r--app-accessibility/emacspeak/Manifest1
-rw-r--r--app-accessibility/emacspeak/emacspeak-56.0.ebuild94
-rw-r--r--app-accessibility/emacspeak/emacspeak-9999.ebuild71
3 files changed, 139 insertions, 27 deletions
diff --git a/app-accessibility/emacspeak/Manifest b/app-accessibility/emacspeak/Manifest
index 1a147ca5f1d9..9245ede94a48 100644
--- a/app-accessibility/emacspeak/Manifest
+++ b/app-accessibility/emacspeak/Manifest
@@ -1 +1,2 @@
DIST emacspeak-39.0.tar.bz2 4989631 BLAKE2B ea58436fd3d7450938de04b74dcefdd9b9c5bee5c8c3bf48dbd2ca5bd5ce5c795a0d4c60ec05ca83c0020ca650b717e378717dc2d68eb56e80653b5045d5b132 SHA512 c0a0c503d6ccc2abb53a8be580997b44e0449c2225e8a64cee73c24d69a28c3f47c0e660a95a6e77dd4d660272ad562ff747ce3c0a989f8fe7c8171f60349173
+DIST emacspeak-56.0.tar.bz2 7158646 BLAKE2B 484b98e5fac51d30bd9b2705308042ed9e0a49a4684ca777cbc60368fdadd8206ef212af514a5940509c84fee3fdcad12486a31a47cac658c912d7573a484fb7 SHA512 9b18fada991b914ddd3ed30950e685c1c164434536c3dd119b9ed52db80e7e31b7399c72a584938bfb63daa7e1aa76a1f377d664cc1118ffa7f0a4cbdddf0818
diff --git a/app-accessibility/emacspeak/emacspeak-56.0.ebuild b/app-accessibility/emacspeak/emacspeak-56.0.ebuild
new file mode 100644
index 000000000000..e9ce5050771c
--- /dev/null
+++ b/app-accessibility/emacspeak/emacspeak-56.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+FORCE_PRINT_ELOG=1
+DISABLE_AUTOFORMATTING=1
+inherit elisp toolchain-funcs readme.gentoo-r1
+
+DESCRIPTION="The emacspeak audio desktop"
+HOMEPAGE="http://emacspeak.sourceforge.net/"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tvraman/emacspeak.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tvraman/emacspeak/releases/download/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE="+espeak"
+
+# Usually need := dep with tcl anyway but in particular, it's needed
+# here as we do a version check in src_compile and bake in the results.
+DEPEND="
+ dev-lang/tcl:=
+ espeak? ( app-accessibility/espeak-ng )
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-tcltk/tclx-8.4
+"
+
+DOC_CONTENTS='
+As of version 39.0 and later, the /usr/bin/emacspeak
+shell script has been removed downstream in Gentoo.
+You should launch emacspeak by another method, for instance
+by adding the following to your ~/.emacs file:
+(load "/usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak-setup.el")
+'
+
+HTML_DOCS=( info/ )
+
+src_configure() {
+ MAKEOPTS+=" -j1"
+
+ tc-export CXX
+
+ emake config
+}
+
+src_compile() {
+ emake emacspeak
+ if use espeak; then
+ local tcl_version="$(echo 'puts $tcl_version;exit 0' |tclsh)"
+ if [[ -z ${tcl_version} ]]; then
+ die 'Unable to detect the installed version of dev-lang/tcl.'
+ fi
+
+ cd servers/native-espeak || die
+ emake TCL_VERSION="${tcl_version}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use espeak; then
+ pushd servers/native-espeak > /dev/null || die
+
+ emake DESTDIR="${D}" install
+ local orig_serverdir="/usr/share/emacs/site-lisp/emacspeak/servers/native-espeak"
+ local serverfile="${ED}${orig_serverdir}/tclespeak.so"
+
+ install -Dm755 "${serverfile}" \
+ "${ED}/usr/$(get_libdir)/emacspeak/tclespeak.so" || die
+ rm -f "${serverfile}" || die
+
+ dosym -r "/usr/$(get_libdir)/emacspeak/tclespeak.so" \
+ "${orig_serverdir}/tclespeak.so"
+ popd > /dev/null || die
+ fi
+
+ dodoc README etc/NEWS* etc/COPYRIGHT
+ einstalldocs
+
+ cd "${ED}"/usr/share/emacs/site-lisp/${PN} || die
+ rm -rf README etc/NEWS* etc/COPYRIGHT install-guide \
+ user-guide || die
+ readme.gentoo_create_doc
+}
diff --git a/app-accessibility/emacspeak/emacspeak-9999.ebuild b/app-accessibility/emacspeak/emacspeak-9999.ebuild
index 67a6062698b4..e9ce5050771c 100644
--- a/app-accessibility/emacspeak/emacspeak-9999.ebuild
+++ b/app-accessibility/emacspeak/emacspeak-9999.ebuild
@@ -1,31 +1,38 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-NEED_EMACS=24
+NEED_EMACS=26.1
FORCE_PRINT_ELOG=1
DISABLE_AUTOFORMATTING=1
-inherit elisp readme.gentoo-r1
+inherit elisp toolchain-funcs readme.gentoo-r1
-if [[ ${PV} == "9999" ]] ; then
+DESCRIPTION="The emacspeak audio desktop"
+HOMEPAGE="http://emacspeak.sourceforge.net/"
+
+if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/tvraman/emacspeak.git"
inherit git-r3
else
- SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.bz2"
+ SRC_URI="https://github.com/tvraman/emacspeak/releases/download/${PV}/${P}.tar.bz2"
KEYWORDS="~amd64 ~ppc ~x86"
fi
-DESCRIPTION="the emacspeak audio desktop"
-HOMEPAGE="http://emacspeak.sourceforge.net/"
LICENSE="BSD GPL-2"
SLOT="0"
IUSE="+espeak"
-DEPEND="espeak? ( app-accessibility/espeak )"
-
-RDEPEND="${DEPEND}
- >=dev-tcltk/tclx-8.4"
+# Usually need := dep with tcl anyway but in particular, it's needed
+# here as we do a version check in src_compile and bake in the results.
+DEPEND="
+ dev-lang/tcl:=
+ espeak? ( app-accessibility/espeak-ng )
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-tcltk/tclx-8.4
+"
DOC_CONTENTS='
As of version 39.0 and later, the /usr/bin/emacspeak
@@ -35,9 +42,13 @@ by adding the following to your ~/.emacs file:
(load "/usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak-setup.el")
'
-HTML_DOCS=( install-guide user-guide )
+HTML_DOCS=( info/ )
src_configure() {
+ MAKEOPTS+=" -j1"
+
+ tc-export CXX
+
emake config
}
@@ -45,33 +56,39 @@ src_compile() {
emake emacspeak
if use espeak; then
local tcl_version="$(echo 'puts $tcl_version;exit 0' |tclsh)"
- if [[ -z $tcl_version ]]; then
+ if [[ -z ${tcl_version} ]]; then
die 'Unable to detect the installed version of dev-lang/tcl.'
fi
- cd servers/linux-espeak || die
+
+ cd servers/native-espeak || die
emake TCL_VERSION="${tcl_version}"
fi
}
src_install() {
emake DESTDIR="${D}" install
- rm "${D}/usr/bin/emacspeak"
+
if use espeak; then
- pushd servers/linux-espeak > /dev/null || die
+ pushd servers/native-espeak > /dev/null || die
+
emake DESTDIR="${D}" install
- local orig_serverdir="/usr/share/emacs/site-lisp/emacspeak/servers/linux-espeak"
- local serverfile="${D}${orig_serverdir}/tclespeak.so"
- install -Dm755 "$serverfile" \
- "${D}/usr/$(get_libdir)/emacspeak/tclespeak.so" || die
- rm -f "$serverfile" || die
- dosym "/usr/$(get_libdir)/emacspeak/tclespeak.so" \
- "$orig_serverdir/tclespeak.so"
+ local orig_serverdir="/usr/share/emacs/site-lisp/emacspeak/servers/native-espeak"
+ local serverfile="${ED}${orig_serverdir}/tclespeak.so"
+
+ install -Dm755 "${serverfile}" \
+ "${ED}/usr/$(get_libdir)/emacspeak/tclespeak.so" || die
+ rm -f "${serverfile}" || die
+
+ dosym -r "/usr/$(get_libdir)/emacspeak/tclespeak.so" \
+ "${orig_serverdir}/tclespeak.so"
popd > /dev/null || die
fi
- dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
+
+ dodoc README etc/NEWS* etc/COPYRIGHT
einstalldocs
- cd "${D}/usr/share/emacs/site-lisp/${PN}" || die
- rm -rf README etc/NEWS* etc/FAQ etc/COPYRIGHT install-guide \
+
+ cd "${ED}"/usr/share/emacs/site-lisp/${PN} || die
+ rm -rf README etc/NEWS* etc/COPYRIGHT install-guide \
user-guide || die
readme.gentoo_create_doc
}