summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-02-11 23:19:01 +0100
committerUlrich Müller <ulm@gentoo.org>2022-02-11 23:24:08 +0100
commitb90a50fab78c1e2bacaeabd1d2ba4cd9be104dc7 (patch)
treef44468b99955c8a34ca2f717b9d0a6d1be488499 /app-accessibility/espeak-ng
parentpackage.mask: Last rite x11-misc/gtk2fontsel (diff)
downloadgentoo-b90a50fab78c1e2bacaeabd1d2ba4cd9be104dc7.tar.gz
gentoo-b90a50fab78c1e2bacaeabd1d2ba4cd9be104dc7.tar.bz2
gentoo-b90a50fab78c1e2bacaeabd1d2ba4cd9be104dc7.zip
app-accessibility/espeak-ng: Replace non-free ieee80.c code
Patch has been accepted upstream. Acked-by: William Hubbs <williamh@gentoo.org> Closes: https://bugs.gentoo.org/832778 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-accessibility/espeak-ng')
-rw-r--r--app-accessibility/espeak-ng/Manifest1
-rw-r--r--app-accessibility/espeak-ng/espeak-ng-1.50-r2.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/app-accessibility/espeak-ng/Manifest b/app-accessibility/espeak-ng/Manifest
index a89c9b5ddaa2..ca6c1169c145 100644
--- a/app-accessibility/espeak-ng/Manifest
+++ b/app-accessibility/espeak-ng/Manifest
@@ -1 +1,2 @@
+DIST espeak-ng-1.50-ieee80.patch.xz 8128 BLAKE2B f9ae3b64d52f18b0dd4bb1ff1832d89fc22c319bccf3f7ada61628569857fded15a426703d035737b829fc8580707876ad09527380890f73df919740b40aa046 SHA512 4183fd13c902bdda27ac7e86fb4e4573ce85ca015aaea757aed27a869e4067a58c99b8f4d3e289710d1359d4fa289c2a4e6d5803845cd454c3dc59f79f4e2e80
DIST espeak-ng-1.50.tar.gz 13665536 BLAKE2B c64c2a474374d4b6fe13bf3a99f5dfb661923c13ebd6c0bc323e7f26d9d90945c7075cc5c8f4b51e5db3303632c8c9daca7a65a1883e09d7c3faf63dd725ea3f SHA512 297dd80a6cdae3e2b8acf6823475220ce89d6a5fb68ea303156ad52cb3e7388049b6921759d4ed4e3d2e2ebd19bf931259e454f74a2ac0b7ecf4ce56c1d60c0c
diff --git a/app-accessibility/espeak-ng/espeak-ng-1.50-r2.ebuild b/app-accessibility/espeak-ng/espeak-ng-1.50-r2.ebuild
new file mode 100644
index 000000000000..5e780ba05fea
--- /dev/null
+++ b/app-accessibility/espeak-ng/espeak-ng-1.50-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Software speech synthesizer for English, and some other languages"
+HOMEPAGE="https://github.com/espeak-ng/espeak-ng"
+SRC_URI="https://github.com/espeak-ng/espeak-ng/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~ulm/distfiles/${P}-ieee80.patch.xz"
+
+LICENSE="GPL-3+ unicode"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+async +klatt l10n_ru l10n_zh man mbrola +sound"
+
+COMMON_DEPEND="
+ !app-accessibility/espeak
+ mbrola? ( app-accessibility/mbrola )
+ sound? ( media-libs/pcaudiolib )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ sound? ( media-sound/sox )
+"
+BDEPEND="
+ virtual/pkgconfig
+ man? ( || ( app-text/ronn-ng app-text/ronn ) )
+"
+
+PATCHES=( "${WORKDIR}"/${P}-ieee80.patch )
+
+DOCS=( CHANGELOG.md README.md docs )
+
+src_prepare() {
+ default
+
+ # disable failing tests
+ rm tests/{language-pronunciation,translate}.test || die
+ sed -i \
+ -e "/language-pronunciation.check/d" \
+ -e "/translate.check/d" \
+ Makefile.am || die
+
+ # https://github.com/espeak-ng/espeak-ng/issues/699
+ # fixed in master
+ sed -i -e "s/int samplerate;/static int samplerate;/" src/espeak-ng.c || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local econf_args
+ econf_args=(
+ $(use_with async)
+ $(use_with klatt)
+ $(use_with l10n_ru extdict-ru)
+ $(use_with l10n_zh extdict-zh)
+ $(use_with l10n_zh extdict-zhy)
+ $(use_with mbrola)
+ $(use_with sound pcaudiolib)
+ --without-libfuzzer
+ --without-sonic
+ --disable-rpath
+ --disable-static
+ )
+ econf "${econf_args[@]}"
+}
+
+src_compile() {
+ # see docs/building.md
+ # The -j1s from compile/test/install may be droppable in next release
+ # (after 1.50). Several bugs have been fixed upstream in git.
+ emake -j1
+}
+
+src_test() {
+ emake check -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" VIMDIR=/usr/share/vimfiles install -j1
+ rm "${ED}"/usr/lib*/*.la || die
+}