summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-07-01 16:19:01 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-07-01 16:23:06 -0500
commit72f9fa47d15b348dbb73c1f44dbad2107cd5062a (patch)
treeada9e35a25a5672e166c641e383317bffa4f69f5 /app-accessibility/espeakup
parentx11-misc/xflux-gui: add python3.10 support (diff)
downloadgentoo-72f9fa47d15b348dbb73c1f44dbad2107cd5062a.tar.gz
gentoo-72f9fa47d15b348dbb73c1f44dbad2107cd5062a.tar.bz2
gentoo-72f9fa47d15b348dbb73c1f44dbad2107cd5062a.zip
app-accessibility/espeakup: 0.90 bump
This version moves to espeak-ng instead of espeak. Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-accessibility/espeakup')
-rw-r--r--app-accessibility/espeakup/Manifest1
-rw-r--r--app-accessibility/espeakup/espeakup-0.90.ebuild58
-rw-r--r--app-accessibility/espeakup/files/espeakup.initd18
3 files changed, 77 insertions, 0 deletions
diff --git a/app-accessibility/espeakup/Manifest b/app-accessibility/espeakup/Manifest
index f0ff5a959177..63475c422dfb 100644
--- a/app-accessibility/espeakup/Manifest
+++ b/app-accessibility/espeakup/Manifest
@@ -1 +1,2 @@
DIST espeakup-0.80.tar.gz 39626 BLAKE2B f36d9776b954e73fd2bc33c7ba97dd323184480549b667ac2afc4dc40a8b98089b8ced16e8b1cb33e6b4c586df27a8d6f782236ef8770bc98a530665e257edcf SHA512 1b7e2bd46c3c13a5305746d2d2810ec94a8660f561e4f679ee4779be1b22178f8ac7de42d626d649710509f7b087b9a2f94608bde203d1bcd6d353229ed9ff83
+DIST espeakup-0.90.tar.gz 25170 BLAKE2B f91a70bad0d985d313852b9e5f72dea4330ab23050ca6904ae5895d513088031f34d878cd64d97dcf2cf02dddc3e9fdabd0826cac98634829019ed3267e27bd8 SHA512 0731835a04063c5eac8ed0ed37cd92cc5d2dd1c58cbd94e158b7dfbb7bc0e2f84a6484fffd9009bf2920652a36fb737044b2e1fb67fb1679ee7150855bc9a15e
diff --git a/app-accessibility/espeakup/espeakup-0.90.ebuild b/app-accessibility/espeakup/espeakup-0.90.ebuild
new file mode 100644
index 000000000000..fac584f93722
--- /dev/null
+++ b/app-accessibility/espeakup/espeakup-0.90.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/williamh/espeakup.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/linux-speakup/espeakup/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+inherit linux-info meson
+
+DESCRIPTION="espeakup is a small lightweight connector for espeak and speakup"
+HOMEPAGE="https://github.com/williamh/espeakup"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="man systemd"
+
+COMMON_DEPEND="app-accessibility/espeak-ng[sound]
+ media-libs/alsa-lib"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="man? ( app-text/ronn )"
+
+CONFIG_CHECK="~SPEAKUP ~SPEAKUP_SYNTH_SOFT"
+ERROR_SPEAKUP="CONFIG_SPEAKUP is not enabled in this kernel!"
+ERROR_SPEAKUP_SYNTH_SOFT="CONFIG_SPEAKUP_SYNTH_SOFT is not enabled in this kernel!"
+
+src_configure() {
+ local emesonargs
+ emesonargs=(
+ $(meson_feature man)
+ $(meson_feature systemd)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ einstalldocs
+ newconfd "${FILESDIR}"/espeakup.confd espeakup
+ newinitd "${FILESDIR}"/espeakup.initd espeakup
+}
+
+pkg_postinst() {
+ elog "To get espeakup to start automatically, it is currently recommended"
+ elog "that you add it to the default run level, by giving the following"
+ elog "command as root."
+ elog
+ elog "rc-update add espeakup default"
+ elog
+ elog "You can also set a default voice now for espeakup."
+ elog "See /etc/conf.d/espeakup for how to do this."
+}
diff --git a/app-accessibility/espeakup/files/espeakup.initd b/app-accessibility/espeakup/files/espeakup.initd
new file mode 100644
index 000000000000..6ef0a339d1c9
--- /dev/null
+++ b/app-accessibility/espeakup/files/espeakup.initd
@@ -0,0 +1,18 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+command=/usr/bin/espeakup
+command_args="${espeakup_opts:-${ESPEAKUP_OPTS}}"
+pidfile=/run/espeakup.pid
+
+depend() {
+ after modules
+ use alsasound pulseaudio
+}
+
+start_pre() {
+ [ -f /sys/accessibility/speakup/synth ] &&
+ echo soft > /sys/accessibility/speakup/synth
+ return 0
+}