summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-18 22:05:34 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-18 22:10:45 -0400
commitd6f18b283e21d3eed783dbfa6a8593e9188e2eef (patch)
treee2ec8e0ac5e7e06e81c04ae0fa9869a79e3ac453 /app-accessibility/orca
parentapp-accessibility/speech-dispatcher: Add Python 3.9 support (diff)
downloadgentoo-d6f18b283e21d3eed783dbfa6a8593e9188e2eef.tar.gz
gentoo-d6f18b283e21d3eed783dbfa6a8593e9188e2eef.tar.bz2
gentoo-d6f18b283e21d3eed783dbfa6a8593e9188e2eef.zip
app-accessibility/orca: Version bump to 40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/Manifest1
-rw-r--r--app-accessibility/orca/orca-40.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index 8a74c31ae4ec..62785f28e3ef 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1 +1,2 @@
DIST orca-3.36.6.tar.xz 3465112 BLAKE2B 227610b5a01027c292cf9a99ecc54f76ad6053d6923325825ed5f81183b39e1e38e70e7a7d88561f0b0c4d212f16465542d57bf4aeed2fa893b8893fa1d3dd49 SHA512 be2752267d46077310eccc4d76dc5e87ce8e1715cc33ff6f8f15b83c9891a2ba98a2d681f893c88df5b0c5ffd8a1ebadc3a4286debf0ff14ba17803d20f902db
+DIST orca-40.0.tar.xz 3603368 BLAKE2B 3ac99f32ee496004e568ce61d5862591556bedfd8dc7ef1b707b62b120f1349ae38bbd427b0d3cc67c7be7334bcc46b067ee44a45c51bcdbdf15ee78c0243f64 SHA512 16e15b1cb4b5a2a3d14ddf9e9277e6b0c65e2ab0a7370fd8bfb830bee9d208ef6b5b3d0c19cc2ff6107f3b0cd41e8ae00881033645f7a309ca3ce65aebd73a1b
diff --git a/app-accessibility/orca/orca-40.0.ebuild b/app-accessibility/orca/orca-40.0.ebuild
new file mode 100644
index 000000000000..f866c6fab92a
--- /dev/null
+++ b/app-accessibility/orca/orca-40.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.34:2
+ >=app-accessibility/at-spi2-core-2.36:2[introspection]
+ >=dev-libs/atk-2.36
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_MULTI_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ dev-libs/atk[introspection]
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_MULTI_USEDEP}]
+ dev-python/setproctitle[${PYTHON_MULTI_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}