summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-17 15:09:02 -0400
committerMatt Turner <mattst88@gentoo.org>2022-05-17 15:10:17 -0400
commit0f7d7d2c73dbb2e533d8d43dc33c9eedb50c6c8d (patch)
treed66f9d2f45645a482c19984fb2cc511d77aac1fe /app-accessibility
parentsys-apps/osinfo-db: Version bump to 20220516 (diff)
downloadgentoo-0f7d7d2c73dbb2e533d8d43dc33c9eedb50c6c8d.tar.gz
gentoo-0f7d7d2c73dbb2e533d8d43dc33c9eedb50c6c8d.tar.bz2
gentoo-0f7d7d2c73dbb2e533d8d43dc33c9eedb50c6c8d.zip
app-accessibility/orca: Version bump to 42.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/orca/Manifest1
-rw-r--r--app-accessibility/orca/orca-42.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index c3a556b43bd4..45d977f6c79f 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,2 +1,3 @@
DIST orca-41.2.tar.xz 3637836 BLAKE2B bebe1d6e37b88f8e1c97c2ee2a599185c2c14d88fc7d12805bb5a7623b1323ad8688cb846b6e733ef02d58390eb390d1dcd2150a0ed50c8109a7468d62f525c2 SHA512 a2d208193aaac48bf12ca22732b338cdcb5299edc7e7b5c75c88f8dee6ad69762287dbb36c25661c08f904b3848a2ca0e60f2d7153e41594944fab509ff3ef07
DIST orca-42.0.tar.xz 3658384 BLAKE2B 7b8b83205e9b8c16021cb3582ca8ada195384b5dee4c93ea9707e5f6133f006d21e2b94c6c65131b73ac5d1072eea423d66d5c4b4e5cd6d2be7cc4fdf3c9ad0f SHA512 dee0f65cd1055293d65eabb360b515763501812264440410332d7c0bf58eff63035f8fee07d61e5caed7c860cdce44ca30b187c6fc1c0417102fb577ff02e340
+DIST orca-42.1.tar.xz 3700132 BLAKE2B 1310a1b43da709e9b273ce21374fff9fa30fbf08d1d0e171eb7eff4511ad5e2bcee12a2d6549a4c0c8e21526fb6f4b3b311d0e09fd6bfa863e29168809df9c10 SHA512 98f016087317666c4dcc7543d16ffb93214075d49d3708a1aa3dc8b6dd5d9d85c52dd31e650f4511371061c58d53e73455a09d6d7b4405b8a972b58ff1d7db91
diff --git a/app-accessibility/orca/orca-42.1.ebuild b/app-accessibility/orca/orca-42.1.ebuild
new file mode 100644
index 000000000000..b5714207dce1
--- /dev/null
+++ b/app-accessibility/orca/orca-42.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.34:2
+ >=app-accessibility/at-spi2-core-2.36:2[introspection]
+ >=dev-libs/atk-2.36
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ dev-libs/atk[introspection]
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}