summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 03:45:06 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:53:48 +0100
commita1ba44b30cbc2f9ebb6dceeb5e015b7f2c64757f (patch)
tree3d49aba2655d76b02de0b4cddf5357f4b20061d8 /app-accessibility
parentapp-accessibility/eflite: eutils-- (diff)
downloadgentoo-a1ba44b30cbc2f9ebb6dceeb5e015b7f2c64757f.tar.gz
gentoo-a1ba44b30cbc2f9ebb6dceeb5e015b7f2c64757f.tar.bz2
gentoo-a1ba44b30cbc2f9ebb6dceeb5e015b7f2c64757f.zip
app-accessibility/nfbtrans: EAPI 7, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild32
1 files changed, 17 insertions, 15 deletions
diff --git a/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild b/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild
index c458fcee9dcd..8509d2d383e6 100644
--- a/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild
+++ b/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild
@@ -1,41 +1,43 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
-DESCRIPTION="braille translator from the National Federation of the Blind"
+DESCRIPTION="Braille translator from the National Federation of the Blind"
HOMEPAGE="http://www.nfb.org/nfbtrans"
SRC_URI="http://www.nfb.org/Images/nfb/Products_Technology/nfbtr774.zip"
+S="${WORKDIR}"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-DEPEND=" >=app-arch/unzip-5.50-r2"
-RDEPEND=""
-
-S=${WORKDIR}
+BDEPEND=" >=app-arch/unzip-5.50-r2"
PATCHES=(
-"${FILESDIR}"/${P}-gentoo-fix.patch
-"${FILESDIR}"/${P}-getline-fix.patch
-"${FILESDIR}"/${P}-respect-ldflags.patch
+ "${FILESDIR}"/${P}-gentoo-fix.patch
+ "${FILESDIR}"/${P}-getline-fix.patch
+ "${FILESDIR}"/${P}-respect-ldflags.patch
)
src_prepare() {
mv MAKEFILE Makefile || die
mv SPANISH.ZIP spanish.zip || die
- emake lowercase
+
default
+
+ emake lowercase
}
src_compile() {
- emake CC=$(tc-getCC) \
+ emake \
+ CC="$(tc-getCC)" \
LIBS= \
- CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" all
+ CFLAGS="${CFLAGS} -DLINUX" \
+ LDFLAGS="${LDFLAGS}" \
+ all
}
src_install() {