summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro@users.noreply.github.com>2023-03-14 19:14:46 -0400
committerSam James <sam@gentoo.org>2023-03-22 05:29:47 +0000
commitcda84f2b9555deb10f258d86aa8282005dae516d (patch)
tree66e3044a33939ae0c18966ed97d52a95eb230425 /app-accessibility
parentmedia-libs/x264: add check for MSA instructions on mips (diff)
downloadgentoo-cda84f2b9555deb10f258d86aa8282005dae516d.tar.gz
gentoo-cda84f2b9555deb10f258d86aa8282005dae516d.tar.bz2
gentoo-cda84f2b9555deb10f258d86aa8282005dae516d.zip
app-accessibility/flite: add openmp check for tests
Forgot this in https://github.com/gentoo/gentoo/pull/30006 Bug: https://bugs.gentoo.org/896106 Signed-off-by: Matoro Mahri <matoro@users.noreply.github.com> Closes: https://github.com/gentoo/gentoo/pull/30128 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/flite/flite-2.2.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/app-accessibility/flite/flite-2.2.ebuild b/app-accessibility/flite/flite-2.2.ebuild
index 5833e0487797..995b34efd8ea 100644
--- a/app-accessibility/flite/flite-2.2.ebuild
+++ b/app-accessibility/flite/flite-2.2.ebuild
@@ -71,6 +71,14 @@ get_audio() {
fi
}
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use test && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use test && tc-check-openmp
+}
+
src_unpack() {
for file in ${A}; do
case "${file}" in