summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-13 22:13:57 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-13 22:25:16 +0200
commitfb676f5c2d2ebd24423e35585ed567566b269aa2 (patch)
tree2a5626f0f955aa74fc758c1404134cca7a9d6c2d /app-accessibility
parentnet-wireless/chirp: prep for python3 (diff)
downloadgentoo-fb676f5c2d2ebd24423e35585ed567566b269aa2.tar.gz
gentoo-fb676f5c2d2ebd24423e35585ed567566b269aa2.tar.bz2
gentoo-fb676f5c2d2ebd24423e35585ed567566b269aa2.zip
app-accessibility/brltty: Remove old (py3.6)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/brltty/Manifest1
-rw-r--r--app-accessibility/brltty/brltty-5.2-r1.ebuild197
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch56
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-sysmacros.patch20
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-udev.patch27
5 files changed, 0 insertions, 301 deletions
diff --git a/app-accessibility/brltty/Manifest b/app-accessibility/brltty/Manifest
index 2618e8dd7d86..5057b79d6e52 100644
--- a/app-accessibility/brltty/Manifest
+++ b/app-accessibility/brltty/Manifest
@@ -1,2 +1 @@
-DIST brltty-5.2.tar.xz 2532684 BLAKE2B 9b0555289177971abe12119f0604eebb196b8f493294741a31c684ebb5546eaccc0a729a8ca6b24e4075f0c29bf371e773743f02e0a102799c44c2293dc9894f SHA512 8e16701e9c9d776c76e3ad0cb4319b2753295fea229bd3f60cb0dffc0b6946037e6f98daafae873238c4eff90d4b8ddb697b7d425e700c5a098aba8fed9eed3f
DIST brltty-6.0.tar.xz 2879976 BLAKE2B 31bd45b63838d119d940492c615deb27ec47389c68afa39f19da3534324914695343344260799a10deae6ca3de41bedf9b0c1de1f78dbe01a89b694c2aa6e265 SHA512 07344fa902ad169967ca39d19b09dfea24e698011031dd63dce3eb997a4cb86622ee9427b216976b3ef60e5cbabb710a621621447c6bfa2313748fc1a1cf4b06
diff --git a/app-accessibility/brltty/brltty-5.2-r1.ebuild b/app-accessibility/brltty/brltty-5.2-r1.ebuild
deleted file mode 100644
index 64b28132085c..000000000000
--- a/app-accessibility/brltty/brltty-5.2-r1.ebuild
+++ /dev/null
@@ -1,197 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-FINDLIB_USE="ocaml"
-
-inherit findlib eutils multilib toolchain-funcs java-pkg-opt-2 flag-o-matic usr-ldscript \
- autotools udev systemd python-r1
-
-DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
-HOMEPAGE="https://brltty.app/"
-SRC_URI="https://brltty.app/archive/${P}.tar.xz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ppc64 x86"
-IUSE="+api +beeper bluetooth +contracted-braille doc +fm gpm iconv icu
- java +midi ncurses nls ocaml +pcm python usb +speech
- tcl X"
-REQUIRED_USE="doc? ( api )
- java? ( api )
- ocaml? ( api )
- python? ( api ${PYTHON_REQUIRED_USE} )
- tcl? ( api )"
-
-COMMON_DEP="bluetooth? ( net-wireless/bluez )
- gpm? ( >=sys-libs/gpm-1.20 )
- iconv? ( virtual/libiconv )
- icu? ( dev-libs/icu:= )
- python? ( ${PYTHON_DEPS} )
- ncurses? ( sys-libs/ncurses:0= )
- nls? ( virtual/libintl )
- tcl? ( >=dev-lang/tcl-8.4.15:0= )
- usb? ( virtual/libusb:0 )
- X? ( x11-libs/libXaw )"
-DEPEND="virtual/pkgconfig
- java? ( >=virtual/jdk-1.4 )
- python? ( >=dev-python/cython-0.16[${PYTHON_USEDEP}] )
- ${COMMON_DEP}"
-RDEPEND="java? ( >=virtual/jre-1.4 )
- ${COMMON_DEP}"
-
-HTML_DOCS=( "${S}"/Documents/Manual-BrlAPI/. )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.2-fix-ldflags.patch
- "${FILESDIR}"/${PN}-5.2-udev.patch
- "${FILESDIR}"/${PN}-5.2-respect-AR.patch
- "${FILESDIR}"/${PN}-5.2-sysmacros.patch
-)
-
-src_prepare() {
- default
-
- java-pkg-opt-2_src_prepare
-
- # The code runs `pkg-config` directly instead of locating a suitable
- # pkg-config wrapper (or respecting $PKG_CONFIG).
- sed -i \
- -e 's/\<pkg-config\>/${PKG_CONFIG:-pkg-config}/' \
- aclocal.m4 configure.ac || die
-
- # We run eautoconf instead of using eautoreconf because brltty uses
- # a custom build system that uses autoconf without the rest of the
- # autotools.
- eautoconf
- python_copy_sources
-}
-
-src_configure() {
- append-cppflags "$($(tc-getPKG_CONFIG) --cflags ncurses)"
- append-libs "$($(tc-getPKG_CONFIG) --libs ncurses)"
-
- tc-export AR LD PKG_CONFIG
- # override prefix in order to install into /
- # braille terminal needs to be available as soon in the boot process as
- # possible
- # Also override localstatedir so that the lib/brltty directory is installed
- # correctly.
- # Disable stripping since we do that ourselves.
- local myconf=(
- --prefix=/
- --localedir=/usr/share/locale
- --includedir=/usr/include
- --localstatedir=/var
- --disable-stripping
- --with-install-root="${D}"
- --with-writable-directory="/run/brltty"
- $(use_enable api)
- $(use_with beeper beep-package)
- $(use_enable contracted-braille)
- $(use_with fm fm-package)
- $(use_enable gpm)
- $(use_enable iconv)
- $(use_enable icu)
- $(use_enable java java-bindings)
- $(use_with midi midi-package)
- $(use_enable nls i18n)
- $(use_enable ocaml ocaml-bindings)
- $(use_with pcm pcm-package)
- $(use_enable speech speech-support)
- $(use_enable tcl tcl-bindings)
- $(use_enable X x)
- $(use_with bluetooth bluetooth-package)
- $(use_with ncurses curses)
- $(use_with usb usb-package) )
-
- econf "${myconf[@]}"
-
- if use python; then
- myconf+=( $(use_enable python python-bindings ) )
-
- python_configure() {
- econf "${myconf[@]}"
- }
- python_foreach_impl run_in_build_dir python_configure
- fi
-}
-
-src_compile() {
- local JAVAC_CONF=""
- local OUR_JNI_FLAGS=""
- if use java; then
- OUR_JNI_FLAGS="$(java-pkg_get-jni-cflags)"
- JAVAC_CONF="${JAVAC} -encoding UTF-8 $(java-pkg_javac-args)"
- fi
-
- emake JAVA_JNI_FLAGS="${OUR_JNI_FLAGS}" JAVAC="${JAVAC_CONF}"
-
- if use python; then
- python_build() {
- cd "Bindings/Python" || die
- emake
- }
- python_foreach_impl run_in_build_dir python_build
- fi
-}
-
-src_install() {
- if use ocaml; then
- findlib_src_preinst
- fi
-
- emake OCAML_LDCONF= install
-
- if use python; then
- python_install() {
- cd "Bindings/Python" || die
- emake install
- }
- python_foreach_impl run_in_build_dir python_install
- fi
-
- if use java; then
- # make install puts the _java.so there, and no it's not $(get_libdir)
- rm -rf "${D}/usr/lib/java"
- java-pkg_doso Bindings/Java/libbrlapi_java.so
- java-pkg_dojar Bindings/Java/brlapi.jar
- fi
-
- insinto /etc
- doins Documents/brltty.conf
- udev_newrules Autostart/Udev/udev.rules 70-brltty.rules
- newinitd "${FILESDIR}"/brltty.rc brltty
- systemd_dounit Autostart/Systemd/brltty.service
- systemd_dotmpfilesd "${FILESDIR}/${PN}.tmpfiles.conf"
-
- libdir="$(get_libdir)"
- mkdir -p "${D}"/usr/${libdir}/
- mv "${D}"/${libdir}/*.a "${D}"/usr/${libdir}/
- gen_usr_ldscript libbrlapi.so
-
- cd Documents || die
- mv Manual-BRLTTY/English/BRLTTY.txt BRLTTY-en.txt || die
- mv Manual-BRLTTY/French/BRLTTY.txt BRLTTY-fr.txt || die
- mv Manual-BrlAPI/English/BrlAPI.txt BrlAPI-en.txt || die
- dodoc CONTRIBUTORS ChangeLog HISTORY README* TODO BRLTTY-*.txt
- if use doc; then
- dodoc BrlAPI-*.txt
- HTML_DOCS="Manual-BRLTTY" einstalldocs
- fi
-
- keepdir /var/lib/BrlAPI
- rmdir "${D}/run/brltty" || die
- rmdir "${D}/run" || die
-}
-
-pkg_postinst() {
- elog
- elog "please be sure ${ROOT}etc/brltty.conf is correct for your system."
- elog
- elog "To make brltty start on boot, type this command as root:"
- elog
- elog "rc-update add brltty boot"
-}
diff --git a/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch b/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch
deleted file mode 100644
index e60ea9a4e509..000000000000
--- a/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch
+++ /dev/null
@@ -1,56 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -377,7 +377,7 @@
- case "${host_os}"
- in
- linux*|gnu*|openbsd*|freebsd*|kfreebsd*|netbsd*|*qnx*|cygwin*|mingw*|elf*)
-- brltty_mkmod_ld_make="-shared"
-+ brltty_mkmod_ld_make="-shared ${LDFLAGS}"
- ;;
- solaris*)
- brltty_mkmod_ld_make="-G"
-@@ -404,7 +404,7 @@
- esac
- if test "${GCC}" = "yes"
- then
-- brltty_cv_prog_mkmod="\$(CC) ${brltty_mkmod_gcc_make=-shared} BRLTTY_OPTIONS_LD2CC([${brltty_mkmod_ld_options}]) -o"
-+ brltty_cv_prog_mkmod="\$(CC) ${brltty_mkmod_gcc_make=-shared} ${LDFLAGS} BRLTTY_OPTIONS_LD2CC([${brltty_mkmod_ld_options}]) -o"
- else
- brltty_cv_prog_mkmod="\$(LD) ${brltty_mkmod_ld_make} ${brltty_mkmod_ld_options} -o"
- fi])
-@@ -414,7 +414,7 @@
- case "${host_os}"
- in
- linux*|gnu*|openbsd*|freebsd*|kfreebsd*|netbsd*|*qnx*|elf*)
-- brltty_mklib_ld_make="-shared"
-+ brltty_mklib_ld_make="-shared ${LDFLAGS}"
- brltty_mklib_ld_options="-soname"
- ;;
- solaris*)
-@@ -449,7 +449,7 @@
- esac
- if test "${GCC}" = "yes"
- then
-- brltty_cv_prog_mklib="\$(CC) ${brltty_mklib_gcc_make=-shared} BRLTTY_OPTIONS_LD2CC([${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>}]) -o"
-+ brltty_cv_prog_mklib="\$(CC) ${brltty_mklib_gcc_make=-shared} ${LDFLAGS} BRLTTY_OPTIONS_LD2CC([${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>}]) -o"
- else
- brltty_cv_prog_mklib="\$(LD) ${brltty_mklib_ld_make} ${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>} -o"
- fi])
---- a/Bindings/OCaml/Makefile.in
-+++ b/Bindings/OCaml/Makefile.in
-@@ -55,13 +55,13 @@
- all : $(OCAML_FILES)
-
- $(OCAML_CLIBS) : brlapi_stubs.$O brlapi
-- $(OCAMLMKLIB) $(API_LDFLAGS) -oc $(OCAML_LIB)_stubs brlapi_stubs.$O
-+ $(OCAMLMKLIB) -ldopt "$(LDFLAGS)" $(API_LDFLAGS) -oc $(OCAML_LIB)_stubs brlapi_stubs.$O
-
- $(OCAML_BCLIB) : $(OCAML_CLIBS) brlapi.cmo
- $(OCAMLC) -a $(OCAMLMKLIB_FLAGS) -o $(OCAML_LIB).cma brlapi.cmo
-
- $(OCAML_NCLIB) : $(OCAML_CLIBS) brlapi.cmx
-- $(OCAMLMKLIB) $(OCAMLMKLIBOPT_FLAGS) -o $(OCAML_LIB) brlapi.cmx
-+ $(OCAMLMKLIB) -ldopt "$(LDFLAGS)" $(OCAMLMKLIBOPT_FLAGS) -o $(OCAML_LIB) brlapi.cmx
-
- brlapi.cmi: brlapi.mli
- $(OCAMLC) -o $@ -c brlapi.mli
diff --git a/app-accessibility/brltty/files/brltty-5.2-sysmacros.patch b/app-accessibility/brltty/files/brltty-5.2-sysmacros.patch
deleted file mode 100644
index f33e46a1890c..000000000000
--- a/app-accessibility/brltty/files/brltty-5.2-sysmacros.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/Programs/system_linux.c
-+++ b/Programs/system_linux.c
-@@ -24,6 +24,7 @@
- #include <fcntl.h>
- #include <sys/ioctl.h>
- #include <sys/stat.h>
-+#include <sys/sysmacros.h>
-
- #include "log.h"
- #include "file.h"
---- a/Programs/brlapi_client.c
-+++ b/Programs/brlapi_client.c
-@@ -73,6 +73,7 @@
- #include <linux/tty.h>
- #include <linux/vt.h>
- #define MAXIMUM_VIRTUAL_CONSOLE MAX_NR_CONSOLES
-+#include <sys/sysmacros.h>
- #endif /* linux */
-
- #ifdef __OpenBSD__
diff --git a/app-accessibility/brltty/files/brltty-5.2-udev.patch b/app-accessibility/brltty/files/brltty-5.2-udev.patch
deleted file mode 100644
index e6d56603b013..000000000000
--- a/app-accessibility/brltty/files/brltty-5.2-udev.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/Autostart/Udev/udev.rules
-+++ b/Autostart/Udev/udev.rules
-@@ -182,20 +182,22 @@
- # FreedomScientific [Focus Blue]
- ENV{PRODUCT}=="f4e/114/*", ENV{BRLTTY_BRAILLE_DRIVER}="fs", GOTO="brltty_usb_run"
-
-+# Seika rules are commented out, because they conflict with USB-to-serial
-+# converters.
- # Device: 10C4:EA60
- # Generic Identifier
- # Vendor: Cygnal Integrated Products, Inc.
- # Product: CP210x UART Bridge / myAVR mySmartUSB light
- # BrailleMemo [Pocket]
- # Seika [Braille Display]
--ENV{PRODUCT}=="10c4/ea60/*", ENV{BRLTTY_BRAILLE_DRIVER}="mm,sk", GOTO="brltty_usb_run"
-+#ENV{PRODUCT}=="10c4/ea60/*", ENV{BRLTTY_BRAILLE_DRIVER}="mm,sk", GOTO="brltty_usb_run"
-
- # Device: 10C4:EA80
- # Generic Identifier
- # Vendor: Cygnal Integrated Products, Inc.
- # Product: CP210x UART Bridge
- # Seika [Note Taker]
--ENV{PRODUCT}=="10c4/ea80/*", ENV{BRLTTY_BRAILLE_DRIVER}="sk", GOTO="brltty_usb_run"
-+#ENV{PRODUCT}=="10c4/ea80/*", ENV{BRLTTY_BRAILLE_DRIVER}="sk", GOTO="brltty_usb_run"
-
- # Device: 1148:0301
- # BrailleMemo [Smart]