summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/389-console/389-console-1.1.7-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/389-console/389-console-1.1.7-r1.ebuild')
-rw-r--r--app-admin/389-console/389-console-1.1.7-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-admin/389-console/389-console-1.1.7-r1.ebuild b/app-admin/389-console/389-console-1.1.7-r1.ebuild
new file mode 100644
index 000000000000..2ede4b173fb5
--- /dev/null
+++ b/app-admin/389-console/389-console-1.1.7-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE=""
+
+inherit java-pkg-2 eutils java-ant-2
+
+DESCRIPTION="A Java based console for remote management 389 server"
+HOMEPAGE="http://port389.org/"
+SRC_URI="http://directory.fedoraproject.org/sources/${P}.tar.bz2
+ http://dev.gentoo.org/~lxnay/${PN}/fedora.png"
+
+LICENSE="LGPL-2.1"
+SLOT="1.1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP="dev-java/jss:3.4
+ dev-java/ldapsdk:4.1
+ >=dev-java/idm-console-framework-1.1"
+
+RDEPEND="|| ( >=virtual/jre-1.6 >=virtual/jdk-1.6 )
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.6
+ ${COMMON_DEP}"
+
+src_prepare() {
+ java-pkg_jar-from ldapsdk-4.1 ldapjdk.jar
+ java-pkg_jar-from jss-3.4 xpclass.jar jss4.jar
+ java-pkg_jar-from idm-console-framework-1.1
+}
+
+src_compile() {
+ eant -Dbuilt.dir="${S}"/build \
+ -Dldapjdk.local.location="${S}" \
+ -Djss.local.location="${S}" \
+ -Dconsole.local.location="${S}" ${antflags} \
+ || die "eant failed"
+}
+
+src_install() {
+ java-pkg_newjar "${S}"/build/389-console-${PV}_en.jar 389-console_en.jar
+ java-pkg_dolauncher ${PN} --main com.netscape.management.client.console.Console \
+ --pwd "/usr/share/dirsrv/html/java/" \
+ --pkg_args "-Djava.util.prefs.systemRoot=\"\$HOME/.${PN}\" -Djava.util.prefs.userRoot=\"\$HOME/.${PN}\"" \
+ || die
+
+ doicon "${DISTDIR}"/fedora.png || die "doicon failed"
+ make_desktop_entry ${PN} "Port389 Management Console" fedora System
+}