summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-03-13 18:53:32 +0100
committerPacho Ramos <pacho@gentoo.org>2022-03-13 19:36:35 +0100
commitfe6e42b4552934023d481f7fe7fe59100c0d47b4 (patch)
treea08bbdebb4339bcfeb66cd125878237a2679e23a /app-admin/abrt
parentgnome-extra/gnome-shell-extension-alphabetical-grid: Bump to 20.0 (diff)
downloadgentoo-fe6e42b4552934023d481f7fe7fe59100c0d47b4.tar.gz
gentoo-fe6e42b4552934023d481f7fe7fe59100c0d47b4.tar.bz2
gentoo-fe6e42b4552934023d481f7fe7fe59100c0d47b4.zip
app-admin/abrt: Bump to 2.15.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-admin/abrt')
-rw-r--r--app-admin/abrt/Manifest1
-rw-r--r--app-admin/abrt/abrt-2.15.1.ebuild127
2 files changed, 128 insertions, 0 deletions
diff --git a/app-admin/abrt/Manifest b/app-admin/abrt/Manifest
index 6e5000396d5c..2e8861aaf461 100644
--- a/app-admin/abrt/Manifest
+++ b/app-admin/abrt/Manifest
@@ -1,2 +1,3 @@
DIST abrt-2.14.6.tar.gz 6057661 BLAKE2B 2ef74203181c89818f283a801c4a1a0f22a01c92ca2415d245dc180ee721b3e29cb75c95e45d738f88b6bbf339fe8bef4e499ab6fecad33399dc8a5af8f98d4c SHA512 eb1ba2f624d51eeccd203bb23060493347f5a9142fad7d0570d46134071d870a9c66b4fbfb8210e7d6f87c0c039f31eb486d18a36b10fba318e2180aa09df9fe
DIST abrt-2.15.0.tar.gz 6122114 BLAKE2B ac075a15d4621596bbe3009bf2e4725040139d78077f85bd4daebbe86504f9aa0a12dcedcf3b5b65404bc2851e93e6b1113dcc37923832c826d572ab9810ef94 SHA512 2d6c1287c1f01990aeb30f956f465c7a6399a6e53dc667602e263c136f94bc4090b58876acba678b29671c0db89ae8e7dd6994cf8d0d2d9fbc375f54ae6cd935
+DIST abrt-2.15.1.tar.gz 6122174 BLAKE2B e3b767929cc2303dcf90a935e0c9ba30641638666925d4707fb0dbed135d8635cd0a58c712f2965969218c64856a5fa3bd20a79410c0e6a5f176a7e82059dda0 SHA512 745c513969b78ee7c76c310a8c2fc0bafd1e50375130fa773ad950bf123ee50cfa237da9b331f2c0af2851b35b162cbc908f2e00d59283867ed8ffd72236d0ea
diff --git a/app-admin/abrt/abrt-2.15.1.ebuild b/app-admin/abrt/abrt-2.15.1.ebuild
new file mode 100644
index 000000000000..6a77875e2603
--- /dev/null
+++ b/app-admin/abrt/abrt-2.15.1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools python-single-r1 tmpfiles xdg
+
+DESCRIPTION="Automatic bug detection and reporting tool"
+HOMEPAGE="https://github.com/abrt/abrt/wiki/ABRT-Project https://github.com/abrt/abrt"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="selinux test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.56:2
+ >=dev-libs/libreport-2.13.0:=[gtk,python]
+ dev-libs/libxml2:2
+ >=gnome-base/gsettings-desktop-schemas-3.15.1
+ net-libs/libsoup:2.4
+ sys-apps/dbus
+ sys-apps/systemd:0=
+ sys-auth/polkit
+ sys-libs/libcap
+ sys-fs/inotify-tools
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+"
+RDEPEND="${DEPEND}
+ acct-user/abrt
+ acct-group/abrt
+ app-arch/cpio
+ app-arch/rpm[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/elfutils
+ dev-libs/json-c:0=
+ sys-apps/util-linux
+ >=sys-devel/gdb-7
+ $(python_gen_cond_dep '
+ dev-libs/satyr[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ $(python_gen_cond_dep 'dev-python/python-systemd[${PYTHON_USEDEP}]')
+ test? (
+ $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang .
+ default
+
+ # Install under proper directory
+ sed -i -e 's:dbusabrtdocdir = ${datadir}/doc/abrt-dbus-${VERSION}/html:dbusabrtdocdir = ${datadir}/doc/${PF}/html:' doc/problems-service/Makefile.am || die
+
+ # Ensure this works for systems with and without /usr merge
+ sed -i -e "s:/usr/bin/bash:$(which bash):" init-scripts/abrtd.service || die
+
+ # Fix hardcoded "pytest-3"
+ sed -i -e "s:pytest-3:pytest:" \
+ configure.ac src/python-problem/tests/Makefile.am src/cli/test || die
+
+ # pyhook test is sensitive to the format of python's error messages, and
+ # fails with certain python versions
+ sed -e '/pyhook.at/ d' \
+ -i tests/Makefile.* tests/testsuite.at || die "sed remove pyhook tests failed"
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+}
+
+src_configure() {
+ myeconfargs=(
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --localstatedir="${EPREFIX}/var"
+ --without-bodhi
+ # package breaks due to not finding libreport-web with bodhi plugin enabled
+ --without-rpm
+ $(usex selinux "" "--without-selinux")
+ --with-python3
+ --without-pythondoc
+ # package breaks due to no sphinx-build-3
+ $(use_with test pythontests)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ python_optimize
+
+ # /var/spool/abrt is created by dev-libs/libreport
+ diropts -m 700 -o abrt -g abrt
+ keepdir /var/spool/abrt-upload
+
+ find "${D}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}/${PN}-2.0.12-r1-init" abrt
+ newconfd "${FILESDIR}/${PN}-2.0.12-r1-conf" abrt
+
+ # Drop empy dirs, handled by tmpfiles
+ rm -r "${ED}"/var/run/ || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ tmpfiles_process abrt.conf
+}