summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Seifert <m.seifert@digitalernachschub.de>2021-10-29 15:28:59 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-29 18:30:10 +0300
commit6e8b7db4f62c4ed31b30b5e6b319368e3f219f8a (patch)
tree6d8ccddcba872e2f6400a300ecf328f979763e48 /app-admin/ansible-base/ansible-base-2.11.4.ebuild
parentwww-apps/radicale: Added missing PYTHON_USEDEP to dependency on dev-python/de... (diff)
downloadgentoo-6e8b7db4f62c4ed31b30b5e6b319368e3f219f8a.tar.gz
gentoo-6e8b7db4f62c4ed31b30b5e6b319368e3f219f8a.tar.bz2
gentoo-6e8b7db4f62c4ed31b30b5e6b319368e3f219f8a.zip
app-admin/ansible-base: Added explicit test dependency on dev-python/bcrypt
Bug: https://bugs.gentoo.org/820668 Signed-off-by: Michael Seifert <m.seifert@digitalernachschub.de> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-admin/ansible-base/ansible-base-2.11.4.ebuild')
-rw-r--r--app-admin/ansible-base/ansible-base-2.11.4.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/app-admin/ansible-base/ansible-base-2.11.4.ebuild b/app-admin/ansible-base/ansible-base-2.11.4.ebuild
deleted file mode 100644
index 18cd0f14676d..000000000000
--- a/app-admin/ansible-base/ansible-base-2.11.4.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://www.ansible.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ansible/ansible.git"
- EGIT_BRANCH="devel"
-else
- MY_PN="${PN/-base/-core}"
- MY_P="${MY_PN}-${PV}"
- SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
- S="${WORKDIR}"/${MY_P}
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- >=dev-python/resolvelib-0.5.3[${PYTHON_USEDEP}]
- <dev-python/resolvelib-0.6.0[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
-"
-DEPEND="
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile() {
- export ANSIBLE_SKIP_CONFLICT_CHECK=1
- distutils-r1_python_compile
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}