summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-02-01 13:06:55 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-02-01 13:09:27 -0600
commit58389ec07d933352815d818e69113a6ffae4bca5 (patch)
tree308e51f8d5268e59e8328fe6d523932c635b1db0 /app-admin/ansible-base
parentsys-cluster/ceph: Fix Python dependencies (diff)
downloadgentoo-58389ec07d933352815d818e69113a6ffae4bca5.tar.gz
gentoo-58389ec07d933352815d818e69113a6ffae4bca5.tar.bz2
gentoo-58389ec07d933352815d818e69113a6ffae4bca5.zip
app-admin/ansible-base: 2.12.2 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible-base')
-rw-r--r--app-admin/ansible-base/Manifest1
-rw-r--r--app-admin/ansible-base/ansible-base-2.12.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-admin/ansible-base/Manifest b/app-admin/ansible-base/Manifest
index c7f97fb7f9f7..de7bc3a6bcfa 100644
--- a/app-admin/ansible-base/Manifest
+++ b/app-admin/ansible-base/Manifest
@@ -1,3 +1,4 @@
DIST ansible-core-2.11.6.tar.gz 6999232 BLAKE2B 5105928881297226e982e42c8027a370ad31869d92ca87d338cdb6e72504a22cf3fe7843921905599c7126c840197fb7799a72c261a007437a437b85c4a65c68 SHA512 d14686afb7b2802be3bca3baf6f3840d33f7994b7c48fcb4d42f871e13e4eb54ffef413e124dbe614a55041c23b509f5e887b687dbb6c4868425957cac45910a
DIST ansible-core-2.11.7.tar.gz 7108269 BLAKE2B c5080161bfffc34382db86f3940dbbf1c8194a4413b20ef28b3c15503aec905acfffc864041496b4f6b4b77966fee3221b80e90d4b952e38513ba9ce506ee1ae SHA512 f37c925c5302eff30d17f52a04d4a5311e38ee5c1d6db4fbdb32970afa362e0522d6ec3d07bddf40137b2f5ec5fa03a2b72e7e1ed313c28c207f65490e49af92
DIST ansible-core-2.12.1.tar.gz 7401160 BLAKE2B 2bc412bade7f7e5dee0e51c78a74b4dea286aca1b82e2217012f168cd529a06887f11d672ff883af6a71c3af6ea1596f6720bcde9ed3696f87b8b5def1a1172b SHA512 89468d172dca502da42b94d0a781906578322ac531b3dfc3cece383b0e93fbec0f199d7b76abfd80d24654d5d939ee66a15b74565f50cca0c72d427aab9f4e08
+DIST ansible-core-2.12.2.tar.gz 7750306 BLAKE2B 629ff38ad98eebdf6b8d7f47355f065589c511fb66b19543ad696b973f6a776b420158ce157c0af5f14b85574808bd5bf3f285607e588949f6cd2e232941e508 SHA512 a9afc3768d27a7049c275da8780e6dcd7da42263fc9065a1df1aabd0d8c54020313e9065349a6f52138e11eafb176348bf2ec33c0c1b08dc9837b7ac832542af
diff --git a/app-admin/ansible-base/ansible-base-2.12.2.ebuild b/app-admin/ansible-base/ansible-base-2.12.2.ebuild
new file mode 100644
index 000000000000..06d9ba54c027
--- /dev/null
+++ b/app-admin/ansible-base/ansible-base-2.12.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansible/ansible.git"
+ EGIT_BRANCH="devel"
+else
+ MY_PN="${PN/-base/-core}"
+ MY_P="${MY_PN}-${PV}"
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+ S="${WORKDIR}"/${MY_P}
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-0.5.3[${PYTHON_USEDEP}]
+ <dev-python/resolvelib-0.6.0[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile() {
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}