summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-11-08 10:55:08 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-11-08 10:57:03 -0600
commit98d9a2b24fdab48b0633bb23a2a0ba11f29796d2 (patch)
tree8c6b00a2a1c053544693ad807d13b48514375a94 /app-admin/ansible-core/ansible-core-2.13.6.ebuild
parentnet-analyzer/icinga2: add 2.13.6 (diff)
downloadgentoo-98d9a2b24fdab48b0633bb23a2a0ba11f29796d2.tar.gz
gentoo-98d9a2b24fdab48b0633bb23a2a0ba11f29796d2.tar.bz2
gentoo-98d9a2b24fdab48b0633bb23a2a0ba11f29796d2.zip
app-admin/ansible-core: add 2.13.6
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible-core/ansible-core-2.13.6.ebuild')
-rw-r--r--app-admin/ansible-core/ansible-core-2.13.6.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-admin/ansible-core/ansible-core-2.13.6.ebuild b/app-admin/ansible-core/ansible-core-2.13.6.ebuild
new file mode 100644
index 000000000000..3655837bc68d
--- /dev/null
+++ b/app-admin/ansible-core/ansible-core-2.13.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansible/ansible.git"
+ EGIT_BRANCH="devel"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-0.5.3[${PYTHON_USEDEP}]
+ <dev-python/resolvelib-0.9.0[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+BDEPEND="
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ test? (
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}