summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/ansible
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/ansible')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-1.9.2.ebuild63
-rw-r--r--app-admin/ansible/ansible-9999.ebuild62
-rw-r--r--app-admin/ansible/files/README.gentoo8
-rw-r--r--app-admin/ansible/files/ansible.env2
-rw-r--r--app-admin/ansible/metadata.xml21
6 files changed, 157 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
new file mode 100644
index 000000000000..282ffd0a6332
--- /dev/null
+++ b/app-admin/ansible/Manifest
@@ -0,0 +1 @@
+DIST ansible-1.9.2.tar.gz 927525 SHA256 c25ef4738b08fdfb3094247c012f3fd1b29972acbd37f988070b2a85f5fbee00 SHA512 6c0b3eaac11e11bf90f5b63c54da86df0cb33b0ee98c987c48a68fa643b39e9f0817884767f2bd9c0f6e8852d37fd1b197d5299abc574fccc181fbb22985d4ad WHIRLPOOL 19d50845b9920d85c5ce0380303144e7a4237e673dd4beb5ff020042d7bac59dc0706cff88f08155029ce1a3aa9decc3c54261f9f16524b6e5e3b42e599d3a6b
diff --git a/app-admin/ansible/ansible-1.9.2.ebuild b/app-admin/ansible/ansible-1.9.2.ebuild
new file mode 100644
index 000000000000..a08091ba13b4
--- /dev/null
+++ b/app-admin/ansible/ansible-1.9.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils readme.gentoo
+
+DESCRIPTION="Radically simple deployment, model-driven configuration management, and command execution framework"
+HOMEPAGE="http://ansible.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x64-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/keyczar[${PYTHON_USEDEP}]
+ >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+# not included in release tarball
+RESTRICT="test"
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ EXAMPLES=( examples )
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+
+ newenvd "${FILESDIR}"/${PN}.env 95ansible
+}
+
+src_install() {
+ distutils-r1_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ optfeature "Alternative ssh transport" dev-python/paramiko
+}
diff --git a/app-admin/ansible/ansible-9999.ebuild b/app-admin/ansible/ansible-9999.ebuild
new file mode 100644
index 000000000000..175ebc5dcfbf
--- /dev/null
+++ b/app-admin/ansible/ansible-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 git-r3 readme.gentoo
+
+DESCRIPTION="Radically simple deployment, model-driven configuration management, and command execution framework"
+HOMEPAGE="http://ansible.com/"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/ansible/ansible.git"
+EGIT_BRANCH="devel"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/keyczar[${PYTHON_USEDEP}]
+ >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ EXAMPLES=( examples )
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+
+ newenvd "${FILESDIR}"/${PN}.env 95ansible
+}
+
+src_install() {
+ distutils-r1_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ optfeature "Alternative ssh transport" dev-python/paramiko
+}
diff --git a/app-admin/ansible/files/README.gentoo b/app-admin/ansible/files/README.gentoo
new file mode 100644
index 000000000000..828e13cddeb6
--- /dev/null
+++ b/app-admin/ansible/files/README.gentoo
@@ -0,0 +1,8 @@
+You can define parameters through shell variables OR use config files
+Examples of config files installed in /usr/share/ansible/examples
+You have to create ansible hosts file!
+More info on http://docs.ansible.com/intro_getting_started.html
+
+Some optional dependencies, you might want to install:
+dev-python/keyczar - needed to support accelerated mode
+dev-python/paramiko - alternative SSH backend"
diff --git a/app-admin/ansible/files/ansible.env b/app-admin/ansible/files/ansible.env
new file mode 100644
index 000000000000..9df5a2ab5a9a
--- /dev/null
+++ b/app-admin/ansible/files/ansible.env
@@ -0,0 +1,2 @@
+# Use ssh transport by default. Comment it out if you want to use paramiko
+ANSIBLE_TRANSPORT="ssh"
diff --git a/app-admin/ansible/metadata.xml b/app-admin/ansible/metadata.xml
new file mode 100644
index 000000000000..cc686a343c0f
--- /dev/null
+++ b/app-admin/ansible/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">ansible</remote-id>
+ <remote-id type="github">ansible/ansible</remote-id>
+ <bugs-to>https://github.com/ansible/ansible/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+Radically simple deployment, model-driven configuration management, and
+command execution framework.
+</longdescription>
+</pkgmetadata>