summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-13 16:27:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-13 16:32:08 -0500
commit94f3fb518412c4577cc506669eff4a7b520c61a3 (patch)
tree66dc66357943441d9785347033b6463a416fcafc /app-admin/ansible
parentnet-print/cnijfilter2: version bump to 5.80 (diff)
downloadgentoo-94f3fb518412c4577cc506669eff4a7b520c61a3.tar.gz
gentoo-94f3fb518412c4577cc506669eff4a7b520c61a3.tar.bz2
gentoo-94f3fb518412c4577cc506669eff4a7b520c61a3.zip
app-admin/ansible: 2.9.9 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.9.9.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 42fdfe7b1b0e..3fc531d1fd03 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1 +1,2 @@
DIST ansible-2.9.7.tar.gz 14215538 BLAKE2B b3882c359d0e71446c81b4f4592a08447656c22ed70358d7eddf36f4a84811d97f047afcdfd57f67664a130cee5c1231a106fc5b77b52cfab8b1be868ee03f81 SHA512 ce029441bcafdc5b44c9fda69f183d4defea84ead5628164caf87306cb97efec68c11b2cce728e90f28290640c320549486a6b4e823710f638d1d2e7c35675a4
+DIST ansible-2.9.9.tar.gz 14222889 BLAKE2B bcacd9271aa0275cff8090819ee5c2832c7b59a287d976ced7e4dad52b5af85350baa1de30f56fdbb92e237c1dd3a9f6ff86cd1af5cb20167331b3f846649d4a SHA512 327c5ece277096f71f10fec2b33a8d2c94ee59b0e22b15bb5ca449da2331b8158239bdbc8e3afd093af358a787f410c7c2e0942010de65a8d9c8719cf83e4abd
diff --git a/app-admin/ansible/ansible-2.9.9.ebuild b/app-admin/ansible/ansible-2.9.9.ebuild
new file mode 100644
index 000000000000..8c8b3a948043
--- /dev/null
+++ b/app-admin/ansible/ansible-2.9.9.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+IUSE="doc test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ dodoc -r examples
+}