summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-09-18 13:59:00 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-09-18 15:03:45 +0200
commite4c88af1916f3542f51e3f79c87500406c446b06 (patch)
tree986add5a1f5fb3a0f3ed90d82cda15163c1ca23c /app-admin/apache-tools
parentdev-perl/XML-Stream: Fix ebuild.badheader (diff)
downloadgentoo-e4c88af1916f3542f51e3f79c87500406c446b06.tar.gz
gentoo-e4c88af1916f3542f51e3f79c87500406c446b06.tar.bz2
gentoo-e4c88af1916f3542f51e3f79c87500406c446b06.zip
app-admin/apache-tools: Bump to v2.2.34
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-admin/apache-tools')
-rw-r--r--app-admin/apache-tools/Manifest1
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.34.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/app-admin/apache-tools/Manifest b/app-admin/apache-tools/Manifest
index 2935dc4a6e5c..8f4d1f6b5d05 100644
--- a/app-admin/apache-tools/Manifest
+++ b/app-admin/apache-tools/Manifest
@@ -1,4 +1,5 @@
DIST httpd-2.2.31.tar.bz2 5610489 SHA256 f32f9d19f535dac63b06cb55dfc023b40dcd28196b785f79f9346779e22f26ac SHA512 5aa47d4b76f692bbd8b309135ff99152df98cf69b505b9daf3f13f7f2a31443eaf4995161adfbc47a133b4d0e091fda2d95fc6b87a956f0ada18d7466ee28e74 WHIRLPOOL a2e3e53c51719cb6f7e641b41788cd89ce7b4d2ea105b403bfa3b3d4479b69c5604228269062f66722594e105e91121d05b1c9f27ca7dc4ecfcf339da8b8375c
DIST httpd-2.2.32.tar.bz2 5777509 SHA256 527bc9d8092d784daf08910dd6c9d2681d6a2325055b2cc69806a0a7df7ed650 SHA512 b1802579f4fc950705ddcf0a24f502ffadbd91d5693fdd3b290ac7ca40122f8fa48132ad1055afae9b841dd55e8bb343239be07ca431b0f60ea081f5c2fad2c3 WHIRLPOOL ee2f1cb74b77f4b3eae7d58bb9bf2728d95a6e215a460d85abf60e220b816cb0e22080169167e3610872e3165951f1cc9ac753f02e46dc75e047a98a1b7384a5
+DIST httpd-2.2.34.tar.bz2 5779739 SHA256 e53183d5dfac5740d768b4c9bea193b1099f4b06b57e5f28d7caaf9ea7498160 SHA512 e6dac5865a48533c025fe17523ee74d68c3a23f9512c9441b78a140e33cfb6835573eb049b0ad424eb5c5ca78a1915778c54e8a409da95fbdd3890cb99e08240 WHIRLPOOL 0bd86b3644fae79c74928c0cd8bc3e4b7d821544a760dbe6459df43210f690d3c4dc74168e029b0b5bbaba6fcd0433aeb4312794455d91b00b7c36c537dfdefd
DIST httpd-2.4.25.tar.bz2 6398218 SHA256 f87ec2df1c9fee3e6bfde3c8b855a3ddb7ca1ab20ca877bd0e2b6bf3f05c80b2 SHA512 6ba4ce1dcef71416cf1c0de2468c002767b5637a75744daf5beb0edd045749a751b3826c4132f594c48e4b33ca8e1b25ebfb63ac4c8b759ca066a89d3261fb22 WHIRLPOOL ccb783875632241e8acf7b43c59163c25b13357b307416abaa3adb0ac868fc547b3cff9585b347e98a8663ec26bea3edad4d42604e6ae86b0db5f769fc11d072
DIST httpd-2.4.27.tar.bz2 6527394 SHA256 71fcc128238a690515bd8174d5330a5309161ef314a326ae45c7c15ed139c13a SHA512 7e7e8070715b74cb6890096a74e194f4c6a49c14bda685b1ad832e84312f1ac4316ea03a430e679502bfd8e1853aefa544ee002a20d0f7e994b9a590c74bc42c WHIRLPOOL 35aeaa01b2bf5772ad21d1011e619befd75fdaade5aa0ca7c61367e7b7a66af28dccf8729a53418f2598199721b68aac7d8c575797ed218150d00af4e8dd4dba
diff --git a/app-admin/apache-tools/apache-tools-2.2.34.ebuild b/app-admin/apache-tools/apache-tools-2.2.34.ebuild
new file mode 100644
index 000000000000..0fe392617c23
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.2.34.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic eutils
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="https://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND="=dev-libs/apr-1*
+ =dev-libs/apr-util-1*
+ dev-libs/expat
+ dev-libs/libpcre
+ kernel_linux? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl:0= )
+ !<www-servers/apache-2.2.4"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S="${WORKDIR}/httpd-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.2.20-Makefile.patch"
+)
+
+src_configure() {
+ # Brain dead check.
+ tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ append-ldflags $(no-as-needed)
+
+ # econf overwrites the stuff from config.layout.
+ econf \
+ --sbindir=/usr/sbin \
+ --with-z=/usr \
+ --with-apr=/usr \
+ --with-apr-util=/usr \
+ --with-pcre=/usr \
+ $(use_enable ssl) \
+ $(usex ssl '--with-ssl=/usr' '')
+}
+
+src_compile() {
+ cd support || die
+ emake
+}
+
+src_install () {
+ cd support || die
+
+ make DESTDIR="${D}" install || die
+
+ # install manpages
+ doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
+ "${S}"/docs/man/{htcacheclean,rotatelogs,ab,logresolve}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+ pushd "${D}"/usr/sbin/ >/dev/null || die
+ for i in *; do
+ dosym /usr/sbin/${i} /usr/sbin/${i}2
+ done
+ popd >/dev/null || die
+
+ # Provide a symlink for ab-ssl
+ if use ssl; then
+ dosym /usr/sbin/ab /usr/sbin/ab-ssl
+ dosym /usr/sbin/ab /usr/sbin/ab2-ssl
+ fi
+
+ # make htpasswd accessible for non-root users
+ dosym /usr/sbin/htpasswd /usr/bin/htpasswd
+ dosym /usr/sbin/htdigest /usr/bin/htdigest
+
+ dodoc "${S}"/CHANGES
+}