summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 20:50:09 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 23:32:23 +0100
commitda532d475a2b5bcca6eed2dedcd4758fd535054f (patch)
tree6f98975f96ff541229ae0e7ae1c5103c6fedb0c7 /app-admin/apachetop
parentapp-admin/aws-elb-tools: Remove old (diff)
downloadgentoo-da532d475a2b5bcca6eed2dedcd4758fd535054f.tar.gz
gentoo-da532d475a2b5bcca6eed2dedcd4758fd535054f.tar.bz2
gentoo-da532d475a2b5bcca6eed2dedcd4758fd535054f.zip
app-admin/apachetop: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-admin/apachetop')
-rw-r--r--app-admin/apachetop/apachetop-0.12.6-r2.ebuild30
-rw-r--r--app-admin/apachetop/files/apachetop-0.12.6-gcc41.patch4
-rw-r--r--app-admin/apachetop/files/apachetop-0.12.6-ncurses.patch166
3 files changed, 187 insertions, 13 deletions
diff --git a/app-admin/apachetop/apachetop-0.12.6-r2.ebuild b/app-admin/apachetop/apachetop-0.12.6-r2.ebuild
index bb433b83e580..bff79f6bb3b7 100644
--- a/app-admin/apachetop/apachetop-0.12.6-r2.ebuild
+++ b/app-admin/apachetop/apachetop-0.12.6-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils autotools
+EAPI=6
+
+inherit autotools
DESCRIPTION="A realtime Apache log analyzer"
HOMEPAGE="http://www.webta.org/projects/apachetop"
@@ -14,22 +15,29 @@ KEYWORDS="amd64 hppa ~mips ppc sparc x86"
IUSE="fam pcre"
RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
fam? ( virtual/fam )
- pcre? ( dev-libs/libpcre )
-"
-DEPEND="${RDEPEND}"
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc41.patch
+ "${FILESDIR}"/${P}-configure.patch
+ "${FILESDIR}"/${P}-maxpathlen.patch
+ "${FILESDIR}"/${P}-ac_config_header.patch
+ "${FILESDIR}"/${P}-ncurses.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc41.patch
- epatch "${FILESDIR}"/${P}-configure.patch
- epatch "${FILESDIR}"/${P}-maxpathlen.patch
- epatch "${FILESDIR}"/${P}-ac_config_header.patch
+ default
eautoreconf
}
src_configure() {
econf \
- --with-logfile=/var/log/apache2/access_log \
+ --with-logfile="${EPREFIX}"/var/log/apache2/access_log \
--without-adns \
$(use_with fam) \
$(use_with pcre)
diff --git a/app-admin/apachetop/files/apachetop-0.12.6-gcc41.patch b/app-admin/apachetop/files/apachetop-0.12.6-gcc41.patch
index 566c9226a3f7..6bfb49d9f9d8 100644
--- a/app-admin/apachetop/files/apachetop-0.12.6-gcc41.patch
+++ b/app-admin/apachetop/files/apachetop-0.12.6-gcc41.patch
@@ -1,5 +1,5 @@
---- src/resolver.h
-+++ src/resolver.h
+--- a/src/resolver.h
++++ b/src/resolver.h
@@ -10,8 +10,8 @@
class Resolver
{
diff --git a/app-admin/apachetop/files/apachetop-0.12.6-ncurses.patch b/app-admin/apachetop/files/apachetop-0.12.6-ncurses.patch
new file mode 100644
index 000000000000..f12c989c3407
--- /dev/null
+++ b/app-admin/apachetop/files/apachetop-0.12.6-ncurses.patch
@@ -0,0 +1,166 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,7 +4,7 @@
+ AC_CONFIG_SRCDIR(src/apachetop.cc)
+
+ AC_CONFIG_AUX_DIR(config)
+-#AC_CONFIG_MACRO_DIR(m4) # 2.58
++AC_CONFIG_MACRO_DIR(m4)
+
+ AC_CONFIG_HEADER(config.h)
+ AM_INIT_AUTOMAKE(apachetop, 0.12.6) # 2.53 only?
+@@ -29,7 +29,6 @@
+ #AC_PROG_CC
+ #AC_PROG_CPP
+ AC_PROG_CXX
+-AC_LANG_CPLUSPLUS
+
+ # Checks for header files.
+ AC_HEADER_STDC
+@@ -120,24 +119,9 @@
+
+ AC_SEARCH_LIBS([socket], [socket])
+ AC_SEARCH_LIBS([inet_addr], [nsl])
+-AC_SEARCH_LIBS([attron], [ncurses])
+-AC_SEARCH_LIBS([tgetstr], [termcap])
+-AC_SEARCH_LIBS([mvprintw], [curses ncurses] ,
+- [] ,
+- [
+- AC_MSG_ERROR([No useful curses library found!])
+- ]
+-)
+
+-AC_SEARCH_LIBS([readline], [readline],
+- [
+- AC_DEFINE(HAVE_READLINE,1,[Define if you have readline library])
+- AC_SUBST(HAVE_READLINE)
+- ] ,
+- [
+- AC_MSG_ERROR(readline library not found)
+- ]
+-)
++PKG_CHECK_MODULES([NCURSES], [ncurses])
++AX_LIB_READLINE
+
+
+ # everything is in CPPFLAGS up to this point, now we move to CXXFLAGS
+--- a/m4/ax_lib_readline.m4
++++ b/m4/ax_lib_readline.m4
+@@ -0,0 +1,107 @@
++# ===========================================================================
++# https://www.gnu.org/software/autoconf-archive/ax_lib_readline.html
++# ===========================================================================
++#
++# SYNOPSIS
++#
++# AX_LIB_READLINE
++#
++# DESCRIPTION
++#
++# Searches for a readline compatible library. If found, defines
++# `HAVE_LIBREADLINE'. If the found library has the `add_history' function,
++# sets also `HAVE_READLINE_HISTORY'. Also checks for the locations of the
++# necessary include files and sets `HAVE_READLINE_H' or
++# `HAVE_READLINE_READLINE_H' and `HAVE_READLINE_HISTORY_H' or
++# 'HAVE_HISTORY_H' if the corresponding include files exists.
++#
++# The libraries that may be readline compatible are `libedit',
++# `libeditline' and `libreadline'. Sometimes we need to link a termcap
++# library for readline to work, this macro tests these cases too by trying
++# to link with `libtermcap', `libcurses' or `libncurses' before giving up.
++#
++# Here is an example of how to use the information provided by this macro
++# to perform the necessary includes or declarations in a C file:
++#
++# #ifdef HAVE_LIBREADLINE
++# # if defined(HAVE_READLINE_READLINE_H)
++# # include <readline/readline.h>
++# # elif defined(HAVE_READLINE_H)
++# # include <readline.h>
++# # else /* !defined(HAVE_READLINE_H) */
++# extern char *readline ();
++# # endif /* !defined(HAVE_READLINE_H) */
++# char *cmdline = NULL;
++# #else /* !defined(HAVE_READLINE_READLINE_H) */
++# /* no readline */
++# #endif /* HAVE_LIBREADLINE */
++#
++# #ifdef HAVE_READLINE_HISTORY
++# # if defined(HAVE_READLINE_HISTORY_H)
++# # include <readline/history.h>
++# # elif defined(HAVE_HISTORY_H)
++# # include <history.h>
++# # else /* !defined(HAVE_HISTORY_H) */
++# extern void add_history ();
++# extern int write_history ();
++# extern int read_history ();
++# # endif /* defined(HAVE_READLINE_HISTORY_H) */
++# /* no history */
++# #endif /* HAVE_READLINE_HISTORY */
++#
++# LICENSE
++#
++# Copyright (c) 2008 Ville Laurikari <vl@iki.fi>
++#
++# Copying and distribution of this file, with or without modification, are
++# permitted in any medium without royalty provided the copyright notice
++# and this notice are preserved. This file is offered as-is, without any
++# warranty.
++
++#serial 7
++
++AU_ALIAS([VL_LIB_READLINE], [AX_LIB_READLINE])
++AC_DEFUN([AX_LIB_READLINE], [
++ AC_CACHE_CHECK([for a readline compatible library],
++ ax_cv_lib_readline, [
++ ORIG_LIBS="$LIBS"
++ for readline_lib in readline edit editline; do
++ for termcap_lib in "" termcap curses ncurses; do
++ if test -z "$termcap_lib"; then
++ TRY_LIB="-l$readline_lib"
++ else
++ TRY_LIB="-l$readline_lib -l$termcap_lib"
++ fi
++ LIBS="$ORIG_LIBS $TRY_LIB"
++ AC_TRY_LINK_FUNC(readline, ax_cv_lib_readline="$TRY_LIB")
++ if test -n "$ax_cv_lib_readline"; then
++ break
++ fi
++ done
++ if test -n "$ax_cv_lib_readline"; then
++ break
++ fi
++ done
++ if test -z "$ax_cv_lib_readline"; then
++ ax_cv_lib_readline="no"
++ fi
++ LIBS="$ORIG_LIBS"
++ ])
++
++ if test "$ax_cv_lib_readline" != "no"; then
++ LIBS="$LIBS $ax_cv_lib_readline"
++ AC_DEFINE(HAVE_LIBREADLINE, 1,
++ [Define if you have a readline compatible library])
++ AC_CHECK_HEADERS(readline.h readline/readline.h)
++ AC_CACHE_CHECK([whether readline supports history],
++ ax_cv_lib_readline_history, [
++ ax_cv_lib_readline_history="no"
++ AC_TRY_LINK_FUNC(add_history, ax_cv_lib_readline_history="yes")
++ ])
++ if test "$ax_cv_lib_readline_history" = "yes"; then
++ AC_DEFINE(HAVE_READLINE_HISTORY, 1,
++ [Define if your readline library has \`add_history'])
++ AC_CHECK_HEADERS(history.h readline/history.h)
++ fi
++ fi
++])dnl
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -6,6 +6,7 @@
+ display.cc hits_circle.cc timed_circle.cc filters.cc \
+ resolver.cc
+
++apachetop_LDADD = $(NCURSES_LIBS)
+
+ noinst_HEADERS = apachetop.h log.h ohtbl.h map.h queue.h \
+ display.h hits_circle.h circle.h timed_circle.h filters.h \