summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-16 08:46:19 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-16 10:02:06 +0200
commitc16c4ac08e2a2246f6794f17e3f869ab9a121de9 (patch)
tree178e2161b1a721b46fe53fb68d15f2a5cd1cf374 /app-admin/awscli
parentdev-python/boto3: Bump to 1.24.31 (diff)
downloadgentoo-c16c4ac08e2a2246f6794f17e3f869ab9a121de9.tar.gz
gentoo-c16c4ac08e2a2246f6794f17e3f869ab9a121de9.tar.bz2
gentoo-c16c4ac08e2a2246f6794f17e3f869ab9a121de9.zip
app-admin/awscli: Bump to 1.25.31
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.25.31.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 5a0102ea92f1..4ae5f047c8e6 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST aws-cli-1.25.27.gh.tar.gz 2230639 BLAKE2B 80101fe2e2b58e7b626c546178ccab451
DIST aws-cli-1.25.28.gh.tar.gz 2231756 BLAKE2B b10d54b79bf16d88c4bd0256a970a640e9d64f903cdd250899f86a73cf6bb4de43d6ad83bddb24fa87684cb50b6c8f286553a609a0a04e8f18dd3428efa1f577 SHA512 a6a1f0ccefc4d9a6dde9efe8908f74b0ba72edcaec1955ebef7d0f7ce8cf4f3cc71fc298ce5120e02173553a22383bcc68fe965c77b77299fbc6e8353ec7cdb6
DIST aws-cli-1.25.29.gh.tar.gz 2231889 BLAKE2B d487859c3b8ec6cc75f5c8ee54f9b0adf0bf0fdec8f36262533b98454c580692566f49daea867453a7f2b240228149e8d031d903b56809adf4d8f60525e25a08 SHA512 913273355f1907d08bac0b1c3f74aeb13966c1bc44c6499a1655c74048e6e711fe9442f5592344478ee4cf292b9fbe573a91c74c4fcf7481f24249e1001d9247
DIST aws-cli-1.25.30.gh.tar.gz 2233472 BLAKE2B b12753046748b11a6067ad4c6e33827631ff1992fc7ffcd603dc048f39ab176208aae9028b473a87981c655445dfddfe77f10e37aafa3878b925668e375aa674 SHA512 e00acbec500294e05d89ae71ecff7cd9dc324b3576423c77c8038767ab115f2244ee64c1c529adce105c3055782341f4fe2ad7fc692f49cc757a7594c4cdeb65
+DIST aws-cli-1.25.31.gh.tar.gz 2233721 BLAKE2B 791bd78851c5643ee72faddc8e4d4e39c94a91e4879d749bcf2cadbe4797cdd448a95dd2b3c626b76e648303ec93fc0338d08f79227f05ff467754810166731b SHA512 586f0fa0f81ec8acc0b79fba5372a37ebcf162981c8fbab31633f63736337cae0b4788bb7a4cdabf6e04800fb63ed6804a6a73a7d5552a9b4c85b4eb273ee6d8
diff --git a/app-admin/awscli/awscli-1.25.31.ebuild b/app-admin/awscli/awscli-1.25.31.ebuild
new file mode 100644
index 000000000000..9f176fa05cc8
--- /dev/null
+++ b/app-admin/awscli/awscli-1.25.31.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}