summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-12 08:05:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-12 08:39:05 +0200
commitf8b5855ba09ce424a7afa60162c6ec6ec2ec5a55 (patch)
tree1ed5f8af5c37ea5811140235f7e9db5027e1b6c5 /app-admin/awscli
parentdev-python/boto3: Bump to 1.17.93 (diff)
downloadgentoo-f8b5855ba09ce424a7afa60162c6ec6ec2ec5a55.tar.gz
gentoo-f8b5855ba09ce424a7afa60162c6ec6ec2ec5a55.tar.bz2
gentoo-f8b5855ba09ce424a7afa60162c6ec6ec2ec5a55.zip
app-admin/awscli: Bump to 1.19.93
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.19.93.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 33383a8c76e4..d7bf6e58e4b8 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -13,3 +13,4 @@ DIST awscli-1.19.89.tar.gz 2016580 BLAKE2B d58c490383750df0ec9482dd0adbd119f0db0
DIST awscli-1.19.90.tar.gz 2017068 BLAKE2B 7e08ee937c90ab82318479d960aa7c8f8274ba46b1267692f93e7756bccd50e35d12174b5e58a3ae3dc540cea7e57e311ca6edc4b43ea7a46475395d7f74ee49 SHA512 502d5a30022c8113d5ff7be3fd33e835e963b9bbe01da0b75892794df7cbc6a08b7bfd948c1b3e3d96e726e0d1d537bf79baf3ca77192e46fabc0ba341e0af26
DIST awscli-1.19.91.tar.gz 2017336 BLAKE2B e74079f8bda95cec8998f85436f5fcc6ec1f3a6a475909c3c8068b876651640c6a0635b22a098812e3b31bc5ae6b7c202f287eb36870c923ddc2cd3376e6ec68 SHA512 ae547b7c5cebea25d63861500f8195e1ea640cbf6b93391d3b3128ad0cc13393441fcd70932cd93ca0bba39b0b1ed98720a063e4ef28d06b7dcb09464b17fdeb
DIST awscli-1.19.92.tar.gz 2018201 BLAKE2B 3e7988878772b978efe1a9043a3d55c129e4ff35b6d3450e65f9bd9fb92effb3d7e0cef389880f4d34726ed72d3249778a50a0b716420c369abe04a2a097685e SHA512 42f91c73c974ab20698259d98b6f31694317cb01127a20d346695b4e73ae45cfdcee0ef241d40e648f5d538d93a2303ba74759508873dbe5071b43ae4f4c80bd
+DIST awscli-1.19.93.tar.gz 2018769 BLAKE2B 95aadfbf6b54e679aee97a1f9194aa8d1667d73b4397e60c00b96bf45ef3e8cfde607b574e0a4017c7660fff7fbf150b9dfb5d2c37f9a12fa86987cadf8c2143 SHA512 2f2ba19659f0c385b629124741218a541024c45d95960069cf362f6e17fa78fd7f2a69042cd9a4e64af540bd4ceac9b451f415c589504fda662e491dec082828
diff --git a/app-admin/awscli/awscli-1.19.93.ebuild b/app-admin/awscli/awscli-1.19.93.ebuild
new file mode 100644
index 000000000000..ff429f8d3a3e
--- /dev/null
+++ b/app-admin/awscli/awscli-1.19.93.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="https://pypi.org/project/awscli/"
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/aws-cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.4.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install nose
+
+PATCHES=(
+ "${FILESDIR}"/awscli-1.19.47-py39.patch
+)
+
+python_test() {
+ distutils_install_for_testing
+ # integration tests require AWS credentials and Internet access
+ nosetests -v tests/{functional,unit} ||
+ die "Tests failed for ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}