summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-03-09 22:38:10 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-03-09 22:38:10 +0100
commit5a7c743ecf0a504246f9c7f0ff89c2798136cdcb (patch)
treef684dd3787dc3c3cceda1a014d873f630cfa62e1 /app-admin/bind_exporter
parentwww-client/chromium: fix bundled ffmpeg to not force lld (diff)
downloadgentoo-5a7c743ecf0a504246f9c7f0ff89c2798136cdcb.tar.gz
gentoo-5a7c743ecf0a504246f9c7f0ff89c2798136cdcb.tar.bz2
gentoo-5a7c743ecf0a504246f9c7f0ff89c2798136cdcb.zip
app-admin/bind_exporter: Initial version
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-admin/bind_exporter')
-rw-r--r--app-admin/bind_exporter/Manifest1
-rw-r--r--app-admin/bind_exporter/bind_exporter-0.2.0_p20180307.ebuild59
-rw-r--r--app-admin/bind_exporter/files/bind_exporter.confd2
-rw-r--r--app-admin/bind_exporter/files/bind_exporter.initd19
-rw-r--r--app-admin/bind_exporter/metadata.xml11
5 files changed, 92 insertions, 0 deletions
diff --git a/app-admin/bind_exporter/Manifest b/app-admin/bind_exporter/Manifest
new file mode 100644
index 000000000000..6606b65e97c2
--- /dev/null
+++ b/app-admin/bind_exporter/Manifest
@@ -0,0 +1 @@
+DIST bind_exporter-0.2.0_p20180307.tar.gz 873965 BLAKE2B e59cbd2ccbd13dd60b673c6816e2d4c151e85ed159daa272996081814f7f276bc686b5d6a94db59e41085d57a12974bd2dcb8ef7696dba3940de705dfc800f25 SHA512 63331f877d988a41b86c0204569a1cd19cbfa176be9e811ef8fa5509d0af4a2f7dda0b27f9ba3b0f3df985f7c075f4535225298ce8808f97497d8bfa3b41256d
diff --git a/app-admin/bind_exporter/bind_exporter-0.2.0_p20180307.ebuild b/app-admin/bind_exporter/bind_exporter-0.2.0_p20180307.ebuild
new file mode 100644
index 000000000000..97396355dc6f
--- /dev/null
+++ b/app-admin/bind_exporter/bind_exporter-0.2.0_p20180307.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/digitalocean/bind_exporter"
+EXPORTER_COMMIT="38ef3a6caa68e8c42a08e72d51e90b00333e6894"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EXPORTER_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Elasticsearch stats exporter for Prometheus"
+HOMEPAGE="https://github.com/digitalocean/bind_exporter"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_prepare() {
+ default
+ sed -i -e "/-s$/d" -e "s/{{.Revision}}/${EXPORTER_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ mkdir -p bin || die
+ GOPATH="${S}" promu build -v --prefix bin || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin bin/${PN}
+ dodoc {README,CHANGELOG}.md
+ popd || die
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ elog "Make sure BIND was built with libxml2 support. You can check with the"
+ elog "following command: named -V | grep libxml2."
+ elog "Configure BIND to open a statistics channel. It's recommended to run"
+ elog "the bind_exporter next to BIND, so it's only necessary to open a port"
+ elog "locally."
+ elog ""
+ elog "statistics-channels {"
+ elog "inet 127.0.0.1 port 8053 allow { 127.0.0.1; };"
+ elog "};"
+}
diff --git a/app-admin/bind_exporter/files/bind_exporter.confd b/app-admin/bind_exporter/files/bind_exporter.confd
new file mode 100644
index 000000000000..e1cc826703e4
--- /dev/null
+++ b/app-admin/bind_exporter/files/bind_exporter.confd
@@ -0,0 +1,2 @@
+# arguments for prometheus bind exporter
+command_args=""
diff --git a/app-admin/bind_exporter/files/bind_exporter.initd b/app-admin/bind_exporter/files/bind_exporter.initd
new file mode 100644
index 000000000000..1167b2430573
--- /dev/null
+++ b/app-admin/bind_exporter/files/bind_exporter.initd
@@ -0,0 +1,19 @@
+#!/sbin/openrc-run
+# Copyright 2016-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="Prometheus bind exporter"
+pidfile=${pidfile:-"/run/${RC_SVCNAME}.pid"}
+user=${user:-${RC_SVCNAME}}
+group=${group:-${RC_SVCNAME}}
+
+command="/usr/bin/bind_exporter"
+command_args="${command_args:-}"
+command_background="true"
+start_stop_daemon_args="--user ${user} --group ${group} \
+ --stdout /var/log/${RC_SVCNAME}/${RC_SVCNAME}.log \
+ --stderr /var/log/${RC_SVCNAME}/${RC_SVCNAME}.log"
+
+depend() {
+ after net
+}
diff --git a/app-admin/bind_exporter/metadata.xml b/app-admin/bind_exporter/metadata.xml
new file mode 100644
index 000000000000..202de383a4e7
--- /dev/null
+++ b/app-admin/bind_exporter/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">digitalocean/bind_exporter</remote-id>
+ </upstream>
+</pkgmetadata>