summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/ccze/ccze-0.2.1-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/ccze/ccze-0.2.1-r3.ebuild')
-rw-r--r--app-admin/ccze/ccze-0.2.1-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-admin/ccze/ccze-0.2.1-r3.ebuild b/app-admin/ccze/ccze-0.2.1-r3.ebuild
new file mode 100644
index 000000000000..9150eed38e6b
--- /dev/null
+++ b/app-admin/ccze/ccze-0.2.1-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit fixheadtails autotools eutils toolchain-funcs
+
+DESCRIPTION="A flexible and fast logfile colorizer"
+HOMEPAGE="http://dev.gentoo.org/~joker/ccze/ccze.txt"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+RESTRICT="test"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/libpcre
+ sys-libs/ncurses"
+
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog ChangeLog-0.1 NEWS THANKS README FAQ )
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/ccze-fbsd.patch
+ epatch "${FILESDIR}"/ccze-segfault.patch
+ epatch "${FILESDIR}"/ccze-ldflags.patch
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+
+ # GCC 4.x fixes
+ sed -e 's/-Wswitch -Wmulticharacter/-Wswitch/' \
+ -i src/Makefile.in || die
+ sed -e '/AC_CHECK_TYPE(error_t, int)/d' \
+ -i configure.ac || die
+
+ eautoreconf
+
+ ht_fix_file Rules.mk.in
+
+ tc-export CC
+}