summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-12-15 21:24:28 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-01-17 16:07:54 +0100
commit0dd57a125efcf48e751c71530fd14a96b6bd4644 (patch)
tree6196c157c2b6b5a570035cf59cd24cc905e0028b /app-admin/cdist
parentsci-libs/silo: drop unused patch (diff)
downloadgentoo-0dd57a125efcf48e751c71530fd14a96b6bd4644.tar.gz
gentoo-0dd57a125efcf48e751c71530fd14a96b6bd4644.tar.bz2
gentoo-0dd57a125efcf48e751c71530fd14a96b6bd4644.zip
app-admin/cdist: bump to 6.9.8 and EAPI 8
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'app-admin/cdist')
-rw-r--r--app-admin/cdist/Manifest1
-rw-r--r--app-admin/cdist/cdist-6.9.8.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-admin/cdist/Manifest b/app-admin/cdist/Manifest
index 25bd9dc06fb0..5b34ab024c5d 100644
--- a/app-admin/cdist/Manifest
+++ b/app-admin/cdist/Manifest
@@ -1 +1,2 @@
DIST cdist-6.9.4.tar.gz 1362226 BLAKE2B c9f9c85b586718e8cd1fe1a88bed5603b0e1c4ddbf398caab033b3adacc056349edb44f9a597f6810a08fef0598260c350d307eafd16c7be43e556a586294800 SHA512 ba139ab404e8167530cc36461bf83443a3b7d289a4cd7daee2286e9610846ac0b75737899defe08dafa873d1c1b369f9a412c828c98c8aae9130713bf5a7ec77
+DIST cdist-6.9.8.tar.gz 1385902 BLAKE2B 6190f09d527a562e490669335d604d3173209bb950448855588a78d48428b8522c8f39327d6455d30242d97bb48d810c319f650a1c0c2fba203a348637dc87c1 SHA512 3c78dd5332a5957750948c52c4b27269ada21b07a2fce0d84019b4fcd3b7ddc6221f0179690d1b3af7e685ffafd739e604f50195fbc36a5494a102b2fa1b732b
diff --git a/app-admin/cdist/cdist-6.9.8.ebuild b/app-admin/cdist/cdist-6.9.8.ebuild
new file mode 100644
index 000000000000..1dae10c0230a
--- /dev/null
+++ b/app-admin/cdist/cdist-6.9.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="A usable configuration management system"
+HOMEPAGE="https://www.cdi.st/ https://code.ungleich.ch/ungleich-public/cdist"
+SRC_URI="https://code.ungleich.ch/ungleich-public/cdist/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs/src dev-python/sphinx_rtd_theme
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ echo "VERSION='${PV}'" > cdist/version.py || die "Failed to set version"
+ distutils-r1_python_prepare_all
+}