summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2021-11-18 22:57:16 +0100
committerPatrice Clement <monsieurp@gentoo.org>2021-11-19 19:25:06 +0100
commit1c7ede657c1f4ee82cba57c70de668f1d370537d (patch)
tree1aa304fd82a86263ca6fc540fbc966540472ae9b /app-admin/clustershell
parentapp-admin/ansible-cmdb: clean up old (diff)
downloadgentoo-1c7ede657c1f4ee82cba57c70de668f1d370537d.tar.gz
gentoo-1c7ede657c1f4ee82cba57c70de668f1d370537d.tar.bz2
gentoo-1c7ede657c1f4ee82cba57c70de668f1d370537d.zip
app-admin/clustershell: bump
* PYTHON_COMPAT bump (3.9) * EAPI 8 bump Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-admin/clustershell')
-rw-r--r--app-admin/clustershell/clustershell-1.8.3-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/clustershell/clustershell-1.8.3-r1.ebuild b/app-admin/clustershell/clustershell-1.8.3-r1.ebuild
new file mode 100644
index 000000000000..53371ad3d6a7
--- /dev/null
+++ b/app-admin/clustershell/clustershell-1.8.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Python framework for efficient cluster administration"
+HOMEPAGE="https://cea-hpc.github.com/clustershell/"
+SRC_URI="https://github.com/cea-hpc/clustershell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+BDEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-libs/openssl:0="
+
+RESTRICT="test" # currently fail
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}
+
+python_test() {
+ cd tests || die
+ nosetests -sv --all-modules || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Some default system-wide config files have been installed into"
+ einfo "/etc/${PN}"
+ einfo
+}