summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2020-11-02 08:18:27 +0100
committerDaniel Pielmeier <billie@gentoo.org>2020-11-02 10:49:49 +0100
commit0fd8a8c809c4603e847267219bb1c87af93027e6 (patch)
treee0fd4e9165e47ccb3b407fc5b1ecd18a96623201 /app-admin/conky
parentdev-python/django: Bump to 3.1.3 (diff)
downloadgentoo-0fd8a8c809c4603e847267219bb1c87af93027e6.tar.gz
gentoo-0fd8a8c809c4603e847267219bb1c87af93027e6.tar.bz2
gentoo-0fd8a8c809c4603e847267219bb1c87af93027e6.zip
app-admin/conky: Build fix for libmicrohttpd.
Thanks to Toralf Förster for the report and Andy Getz for the patch. Closes: https://bugs.gentoo.org/736172 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/conky-1.10.8-r10.ebuild1
-rw-r--r--app-admin/conky/conky-1.11.6-r1.ebuild4
-rw-r--r--app-admin/conky/files/conky-1.10.8-fpermissive.patch14
-rw-r--r--app-admin/conky/files/conky-1.11.6-fpermissive.patch31
4 files changed, 50 insertions, 0 deletions
diff --git a/app-admin/conky/conky-1.10.8-r10.ebuild b/app-admin/conky/conky-1.10.8-r10.ebuild
index 4097461fbccc..66c0ffbf31c9 100644
--- a/app-admin/conky/conky-1.10.8-r10.ebuild
+++ b/app-admin/conky/conky-1.10.8-r10.ebuild
@@ -71,6 +71,7 @@ PATCHES=(
"${FILESDIR}"/${P}-portmon.patch
"${FILESDIR}"/${P}-clang.patch
"${FILESDIR}"/${P}-virtual-sinks.patch
+ "${FILESDIR}"/${P}-fpermissive.patch
)
DISABLE_AUTOFORMATTING="yes"
diff --git a/app-admin/conky/conky-1.11.6-r1.ebuild b/app-admin/conky/conky-1.11.6-r1.ebuild
index 7ed7c4ce1909..91a172007104 100644
--- a/app-admin/conky/conky-1.11.6-r1.ebuild
+++ b/app-admin/conky/conky-1.11.6-r1.ebuild
@@ -75,6 +75,10 @@ CONFIG_CHECK="~IPV6"
DOCS=( README.md AUTHORS )
+PATCHES=(
+ "${FILESDIR}"/${P}-fpermissive.patch
+)
+
DISABLE_AUTOFORMATTING="yes"
DOC_CONTENTS="You can find sample configurations at ${ROOT}/usr/share/doc/${PF}.
To customize, copy to \${XDG_CONFIG_HOME}/conky/conky.conf
diff --git a/app-admin/conky/files/conky-1.10.8-fpermissive.patch b/app-admin/conky/files/conky-1.10.8-fpermissive.patch
new file mode 100644
index 000000000000..42abeb831cd6
--- /dev/null
+++ b/app-admin/conky/files/conky-1.10.8-fpermissive.patch
@@ -0,0 +1,14 @@
+--- conky-1.10.8/src/conky.cc.orig 2020-08-28 13:17:22.330113596 -0400
++++ conky-1.10.8/src/conky.cc 2020-08-28 13:19:48.564891015 -0400
+@@ -478,9 +478,9 @@
+ struct MHD_Daemon *httpd;
+ static conky::simple_config_setting<bool> http_refresh("http_refresh", false, true);
+
+-int sendanswer(void *cls, struct MHD_Connection *connection, const char *url, const char *method, const char *version, const char *upload_data, size_t *upload_data_size, void **con_cls) {
++MHD_Result sendanswer(void *cls, struct MHD_Connection *connection, const char *url, const char *method, const char *version, const char *upload_data, size_t *upload_data_size, void **con_cls) {
+ struct MHD_Response *response = MHD_create_response_from_data(webpage.length(), (void*) webpage.c_str(), MHD_NO, MHD_NO);
+- int ret = MHD_queue_response (connection, MHD_HTTP_OK, response);
++ MHD_Result ret = MHD_queue_response (connection, MHD_HTTP_OK, response);
+ MHD_destroy_response(response);
+ if(cls || url || method || version || upload_data || upload_data_size || con_cls) {} //make compiler happy
+ return ret;
diff --git a/app-admin/conky/files/conky-1.11.6-fpermissive.patch b/app-admin/conky/files/conky-1.11.6-fpermissive.patch
new file mode 100644
index 000000000000..1ac1173ba646
--- /dev/null
+++ b/app-admin/conky/files/conky-1.11.6-fpermissive.patch
@@ -0,0 +1,31 @@
+From 16be0e1571a586168855bedb6da1ddc732b0bbf4 Mon Sep 17 00:00:00 2001
+From: Brenden Matthews <brenden@brndn.io>
+Date: Thu, 22 Oct 2020 13:02:00 -0400
+Subject: [PATCH] Build fix for libmicrohttpd.
+
+---
+ src/conky.cc | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/src/conky.cc b/src/conky.cc
+index 79633a40..b1743466 100644
+--- a/src/conky.cc
++++ b/src/conky.cc
+@@ -322,12 +322,13 @@ struct MHD_Daemon *httpd;
+ static conky::simple_config_setting<bool> http_refresh("http_refresh", false,
+ true);
+
+-int sendanswer(void *cls, struct MHD_Connection *connection, const char *url,
+- const char *method, const char *version, const char *upload_data,
+- size_t *upload_data_size, void **con_cls) {
++MHD_Result sendanswer(void *cls, struct MHD_Connection *connection,
++ const char *url, const char *method, const char *version,
++ const char *upload_data, unsigned long *upload_data_size,
++ void **con_cls) {
+ struct MHD_Response *response = MHD_create_response_from_buffer(
+ webpage.length(), (void *)webpage.c_str(), MHD_RESPMEM_PERSISTENT);
+- int ret = MHD_queue_response(connection, MHD_HTTP_OK, response);
++ MHD_Result ret = MHD_queue_response(connection, MHD_HTTP_OK, response);
+ MHD_destroy_response(response);
+ if (cls || url || method || version || upload_data || upload_data_size ||
+ con_cls) {} // make compiler happy