summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-12-07 15:36:57 +0100
committerFabian Groffen <grobian@gentoo.org>2019-12-07 15:38:01 +0100
commit6b7cf0af64a5bdcd3e98b0e89e4202cd3f35ebdf (patch)
tree07bf66af6b6386679f41646d8187fe80d9b5fc1c /app-admin/diamond/diamond-9999.ebuild
parentdev-python/pyproj: Fix the fix (diff)
downloadgentoo-6b7cf0af64a5bdcd3e98b0e89e4202cd3f35ebdf.tar.gz
gentoo-6b7cf0af64a5bdcd3e98b0e89e4202cd3f35ebdf.tar.bz2
gentoo-6b7cf0af64a5bdcd3e98b0e89e4202cd3f35ebdf.zip
app-admin/diamond-4.0.515.20180315: bump for py3 support
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-admin/diamond/diamond-9999.ebuild')
-rw-r--r--app-admin/diamond/diamond-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-admin/diamond/diamond-9999.ebuild b/app-admin/diamond/diamond-9999.ebuild
index 57df76bc0741..73f30e45464a 100644
--- a/app-admin/diamond/diamond-9999.ebuild
+++ b/app-admin/diamond/diamond-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
if [[ ${PV} = 9999* ]]; then
inherit git-r3
@@ -13,7 +13,7 @@ else
S=${WORKDIR}/Diamond-${PV}
fi
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1 prefix
@@ -55,6 +55,7 @@ python_test() {
python_install() {
export VIRTUAL_ENV=1
distutils-r1_python_install
+ python_optimize
mv "${ED}"/usr/etc "${ED}"/ || die
rm "${ED}"/etc/diamond/*.windows # won't need these
sed -i \