summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-08-07 18:58:06 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-07 19:13:01 +0200
commitd8ed5247f9e56d317eae3510aa26faccbcf2aa69 (patch)
tree9362a9d56cb7bf665d8b65f29ab212329c10ad2a /app-admin/dio/dio-1.5.2-r1.ebuild
parentdev-python/cliff-tablib: drop py34 support (diff)
downloadgentoo-d8ed5247f9e56d317eae3510aa26faccbcf2aa69.tar.gz
gentoo-d8ed5247f9e56d317eae3510aa26faccbcf2aa69.tar.bz2
gentoo-d8ed5247f9e56d317eae3510aa26faccbcf2aa69.zip
app-admin/dio: fix build with sys-libs/ncurses[tinfo]
Also bumped to EAPI=7 Closes: https://bugs.gentoo.org/646802 Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'app-admin/dio/dio-1.5.2-r1.ebuild')
-rw-r--r--app-admin/dio/dio-1.5.2-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-admin/dio/dio-1.5.2-r1.ebuild b/app-admin/dio/dio-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..2a0d993e8a0e
--- /dev/null
+++ b/app-admin/dio/dio-1.5.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A device I/O monitoring tool"
+HOMEPAGE="https://github.com/donaldmcintosh/dio"
+SRC_URI="https://github.com/donaldmcintosh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}/src"
+
+DOCS=( "README" "../README.md" )
+HTML_DOCS=( "../site/www.diodio.org/." )
+
+src_prepare() {
+ # Include the 'tinfo' lib, if sys-libs/ncurses is compiled with USE="tinfo"
+ if has_version -d 'sys-libs/ncurses[tinfo]'; then
+ sed -e 's/lcurses/& -ltinfo/' -i Makefile || die
+ fi
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin dio
+ doman dio.1
+ einstalldocs
+}