summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Janda <felix.janda@posteo.de>2016-10-14 19:18:23 -0400
committerPatrice Clement <monsieurp@gentoo.org>2016-10-15 17:11:21 +0200
commit40ac03c6a01b8cfac6c5a5335fcc6786dfd22a3a (patch)
treecfa75ad9da4e54016078ff06e284f8f522d27c84 /app-admin/doas/doas-6.0.ebuild
parentnet-dns/knot: version bump to 2.3.1. (diff)
downloadgentoo-40ac03c6a01b8cfac6c5a5335fcc6786dfd22a3a.tar.gz
gentoo-40ac03c6a01b8cfac6c5a5335fcc6786dfd22a3a.tar.bz2
gentoo-40ac03c6a01b8cfac6c5a5335fcc6786dfd22a3a.zip
app-admin/doas: new package.
doas allows to run programs as another user, and is a lightweight alternative to sys-apps/sudo. Gentoo-Bug: https://bugs.gentoo.org/597010 Closes: https://github.com/gentoo/gentoo/pull/2560 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-admin/doas/doas-6.0.ebuild')
-rw-r--r--app-admin/doas/doas-6.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/doas/doas-6.0.ebuild b/app-admin/doas/doas-6.0.ebuild
new file mode 100644
index 000000000000..5469c661ce53
--- /dev/null
+++ b/app-admin/doas/doas-6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Run commands as super user or another user, alternative to sudo from OpenBSD"
+
+MY_PN=OpenDoas
+MY_P=${MY_PN}-${PV}
+HOMEPAGE="https://github.com/Duncaen/OpenDoas"
+SRC_URI="https://github.com/Duncaen/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE="pam"
+
+RDEPEND="pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ virtual/yacc"
+
+src_prepare()
+{
+ default
+ sed -i 's/-Werror //' Makefile || die
+}
+
+src_configure()
+{
+ tc-export CC AR
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
+ $(use_with pam) \
+ || die
+}